[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#215471: marked as done (failure report; exit 11 with errors about scsi io errors on non-scsi system)

Your message dated Wed, 12 Jan 2011 00:21:06 +0000
with message-id <1294791666.3497.151.camel@eeepc.Belkin>
and subject line 
has caused the Debian Bug report #215471,
regarding failure report; exit 11 with errors about scsi io errors on non-scsi system
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

215471: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=215471
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Severity: normal


Tue Sep 23 13:36:10 CEST 2003

uname -a: Linux (none) 2.4.20-1-386 Sat Mar 22 12:11:40 EST 2003 i686 unknown
Date: Tue Sep 23 13:36:10 CEST 2003


Booted off floppy, installed net drivers from floppy, rest of retreiving is via
http through a proxy.

Processor: Pentium III 600 MHz
Memory: 128 MB
Root Device: FUJITSU MPD3108AT, ATA DISK drive
Root Size/partition table:i

I don't have the partition table created by the installer handy.  But it was something like

6 G linux root
2 G Windows/DOS unused
2.5 swap

The windows/DOS + swap I have since combined into a 4 G play area and 256 M

Output of lspci:
00:00.0 Host bridge: Intel Corp. 82810E DC-133 GMCH [Graphics Memory Controller Hub] (rev 03)
00:01.0 VGA compatible controller: Intel Corp. 82810E DC-133 CGC [Chipset Graphics Controller] (rev 03)
00:1e.0 PCI bridge: Intel Corp. 82801AA PCI Bridge (rev 02)
00:1f.0 ISA bridge: Intel Corp. 82801AA ISA Bridge (LPC) (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801AA IDE (rev 02)
00:1f.2 USB Controller: Intel Corp. 82801AA USB (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801AA AC'97 Audio (rev 02)
01:0b.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O] (static config)
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [ ]
Partition hard drives:  [E]
Automatically Partition Hard Drives [O]
Create file systems:    [ok, done automatically above]
Mount partitions:       [ok, done automatically above ]
Install base system:    [E]
Install boot loader:    [O]
Reboot:                 [ ]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Partition hard drives:  [E]

An error or warning message was logged while running partitioner partioner''s
postinst exited with status 11

sda : block size assume to be 512 bytes, disk size 1GB
/dev/scsi/host0/bus0/target0/lun0: I/O error: dev 08:00, sector 0
I/O error: dev 08:00, sector 0
unable to read partition table

I don't have a SCSI drive on the system.  Maybe it was confused about the ZIP

I then ran the autopartitioner.  It succeeded, even if it gave me 2.5 G swap.
I later (post installation) reduced the amount of swap.

Install base system:    [E]

Installation appeared to fail the first time, or at least after I chose
'Install the base System'  then waiting a few minutes I looked back and the
main menu had chosen 'Install the base system again'.  I chose that again and
this time saw the following error messages:

Base installation error
debootstrap exited with an error (return value 1)
You might find more information in /target/var/log/debootstrap.log
# cat /target/var/log/debootstrap.log
id: unknown group name: 0
[: 176: 0: unexpected operator
ln: /target/usr/bin/awk: File exists

I ran it again and see that the first two errors appear in the log fairly early
and don't appear to be fatal, the awk error might be the killer, I tried
deleting /target/use/bin/awk and trying the install again.

Now I get a treally nice looking error i:

Setting up dpkg (1.10.10)
Moving /usr/info/dir to /usr/share/info/dir
mv: cannot stat '/usr/info/dir': No such file or directory
dpkg: error processing dpkg (--install)

So I did:
rm /target/use/bin/awk
mkdir /target/usr/info/dir

And tried the base install again.

mv: cannot overwrite non-directory '/usr/share/info/dir' with directory '/usr/info/dir'

So I did:
ls -l /target/usr/share/info/dir
-rw-r--r--  1 root  . . . .
rm /target//usr/share/info/dir
rm /target/use/bin/awk

It failed again with :
mv: cannot overwrite non-directory '/usr/share/info/dir' with directory '/usr/info/dir'

So I did rm -rf /target//usr/share/info/dir* while installing the base system,
and it appeard to work, (the end of debootstrap.log looked ok, it ended with a bunch of start-stop-daemon calls, and then it said 'Hangup'.

In the end I did:

cp /usr/sbin/debootstrap /usr/sbin/debootstrap.real
echo "#!/bin/sh" > /usr/sbin/debootstrap
echo "exit 0" > /usr/sbin/debootstrap

And it succeeded.

After the reboot I had the same problem (complaining about /usr/share/info/dir)
when apt tried to install dpkg.

-- System Information:
Debian Release: testing/unstable
Architecture: i386
Kernel: Linux woof 2.4.22-1-686 #1 Fri Sep 5 23:04:29 EST 2003 i686

--- End Message ---
--- Begin Message ---

Thanks for your report.
Closing as it's an installation report from debian installer version
which isn't supported anymore.
Feel free to test and report any issues against the current debian
installer release (Squeeze RC1) which supports more hardware and also
it's improved.


Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: