[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#414516: marked as done (debian-installer: RAID/crypto/USB problems)

Your message dated Tue, 11 Jan 2011 23:31:41 +0000
with message-id <1294788701.3497.80.camel@eeepc.Belkin>
and subject line 
has caused the Debian Bug report #414516,
regarding debian-installer: RAID/crypto/USB problems
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

414516: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=414516
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Version: 2007.03.10 snapshot
Severity: normal

I've installed recently Debian etch on my machine with idstaller snapshot 
from 2007.03.10. Generally, everything is fine and system working ok, but 
I've experienced two problems during installation.

I've used standard installation mode and partitioned HDD-s the following 

/dev/sda (SATA) -> /dev/sda1 -\                         /- LVM 1 -> ext3 (/)
/dev/sdb (SATA) -> /dev/sdb1  -> software RAID5 -> LVM <
/dev/sdc (SATA) -> /dev/sdc1 -/                         \- LVM 2 ->
						-> crypto -> xfs (/storage)

/dev/sdd (USB)  drive used to boot installer
/dev/sde (USB)  -> /dev/sde1 -> ext3 (/boot)

(hope this picture looks good enough)

So, the first problem was to make a RAID5 array. I've 
partitioned /dev/sd{a,b,c} to have one partition for the whole drive, set 
it as "physical storage for RAID" (or how it's called in installer, sorry, 
can't remember exact name now), went to RAID configuration, saved changes 
and it just said that I have no partitions of type "Linux RAID autodetect". 
That surprised me, I've checked physical partitions several times, 
repartitioned them, tried different things but had no luck. Then I've just 
switched to the shell, ran fdisk on every drive and saw partitions had 
type "83" which is just "Linux". I've fixed them manually with fdisk to 
have type "fd", "Linux RAID autodetect" and only then I was able to set up 
software RAID on this three partitions in installer.

LVM setup went fine and then I've made a mistake when setting up crypto 
physical storage. Originally I had a plan to use two-factor authentication 
(passworded key file), but as installer has no support for this yet, I've 
tried to use "random key" option thinking it would give me an option to use 
key file. I've realized I've a mistake when installer said that its 
intended to use for swap area, crypting it with different key on every 
boot. OK, but how do I change crypto settings for a given volume? I've 
tried to delete partition on crypto volume, that works fine, leaving it 
with "FREE SPACE", but there is no way to delete crypto volume itself! 
Tried to delete LVM volume, but that doesn't work too because LVM volume is 
used for crypto volume, so it's busy. I've found no way to solve this and 
just rebooted installer.

I've used USB flash (no CD on machine, actually no monitor/keyboard either, 
but 'console=ttyS0,115200n8' worked absolutely fine) to boot installer and 
thought of making machine boot from USB too, because all the hard drives 
here are assembled in RAID5 array and I see no way to boot machine from 
RAID5 (maybe I'm wrong and GRUB solves this somehow), so I've tried to set 
up another USB flash as /boot partition to boot machine from there and 
maybe set up this flash to contain crypto key later. Well, I didn't expect 
that this setup will work out of the box, so no surprises here - it doesn't 
work. :) So I had to manually reinstall GRUB on flash on another machine, 
fix (hd4,0) reference to (hd0,0) and then it worked fine.

Although on boot system complained about not being able to fsck /boot as it 
moved from /dev/sde1 to /dev/sdd1 (disconnected flash used to boot 
installer), but that's no big deal, fixed in fstab and will try to setup 
udev properly for this.

Well, that's my experience on Debian etch install. Anything else works 
absolutely fine, hope this helps fix RAID/crypto (don't think anyone cares 
about USB /boot that much) issues before release.

-- System Information:
Debian Release: 4.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)
Shell:  /bin/sh linked to /bin/bash
Kernel: Linux 2.6.18-4-amd64
Locale: LANG=en_US.UTF-8, LC_CTYPE=en_US.UTF-8 (charmap=UTF-8)

 http://roman.khimov.ru                                              .o.
mailto: roman@khimov.ru                                              ..o
gpg --keyserver hkp://subkeys.pgp.net --recv-keys 0xE5E055C3         ooo

--- End Message ---
--- Begin Message ---

Thanks for your report.
Closing as it's an installation report from Etch which isn't supported
Feel free to test and report any issues against the current debian
installer release (Squeeze RC1) which supports more hardware and also
it's improved.


Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: