[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#275262: marked as done (Boot loader install failed on a Mylex Acceleraid 170 RAID adapter)

Your message dated Wed, 12 Jan 2011 00:01:17 +0000
with message-id <1294790477.3497.134.camel@eeepc.Belkin>
and subject line 
has caused the Debian Bug report #226758,
regarding Boot loader install failed on a Mylex Acceleraid 170 RAID adapter
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

226758: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=226758
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports
Severity: critical

Debian-installer-version: pre-rc2
uname -a: Linux stm 2.6.8-1-686 #1 Tue Sep 14 00:22:58 EDT 2004 i686 GNU/Linux
Date: 2004-10-1
Method: How did you install?  What did you boot off?  If network
      install, from where?  Proxied?
Installed from sarge-i386-netinst.iso

Machine: Custom made server with Mylex Acceleraid 170, 5 SCSI disks, one IDE disk
Processor: Athlon64 3200
Memory: 2Gb ECC
Root Device: /dev/rd/c0d0p1
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.
proc            /proc           proc    defaults        0       0
/dev/rd/c0d0p1  /               ext3    defaults,errors=remount-ro      0       1
/dev/rd/c0d0p3  /home           xfs     usrquota,grpquota               0       2
/dev/rd/c0d0p2  none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/hda1       /mnt/disk2      reiserfs        defaults        0       0

Output of lspci and lspci -n:
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8385 [K8T800 AGP] Host Bridge (rev 01)
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8237 PCI bridge [K8T800 South]
0000:00:0a.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Gigabit Ethernet 10/100/1000Base-T Adapter (rev 13)
0000:00:0c.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:0d.0 RAID bus controller: Mylex Corporation AcceleRAID 352/170/160 support Device (rev 02)
0000:00:0f.0 RAID bus controller: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
0000:00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
0000:00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
0000:00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
0000:00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
0000:00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
0000:00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [K8T800 South]
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV100 QY [Radeon 7000/VE]

0000:00:00.0 0600: 1106:3188 (rev 01)
0000:00:01.0 0604: 1106:b188
0000:00:0a.0 0200: 11ab:4320 (rev 13)
0000:00:0c.0 0200: 10ec:8139 (rev 10)
0000:00:0d.0 0104: 1069:0050 (rev 02)
0000:00:0f.0 0104: 1106:3149 (rev 80)
0000:00:0f.1 0101: 1106:0571 (rev 06)
0000:00:10.0 0c03: 1106:3038 (rev 81)
0000:00:10.1 0c03: 1106:3038 (rev 81)
0000:00:10.2 0c03: 1106:3038 (rev 81)
0000:00:10.3 0c03: 1106:3038 (rev 81)
0000:00:10.4 0c03: 1106:3104 (rev 86)
0000:00:11.0 0601: 1106:3227
0000:00:18.0 0600: 1022:1100
0000:00:18.1 0600: 1022:1101
0000:00:18.2 0600: 1022:1102
0000:00:18.3 0600: 1022:1103
0000:01:00.0 0300: 1002:5159

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [E]

While install went fine, boot loader was incorrectly installed because grub tought that the IDE disk was the first disk in the system.
Of course bios was configured to boot from the RAID card and not from the ide disk (installed only for backup purposes).
So grug assigned hd0 to /dev/hda and hd1 /dev/hdb and of course the system could not boot.
I booted with knoppix, changed the drive assignations, and rebooted but there was a kernel panic trying to mount root_pivot (or something similar).

I had to boot again with knoppix and install lilo with a hand made lilo.con since liloconfig is unable to handle raid devices.

Another problem is that, while doing the most basic install, I got the system with libc6-dev, gcc, g++ and several other packages useful only on development systems like binutils, make, flex, bison, etc.

Older installers did not put development tools by default.

--- End Message ---
--- Begin Message ---

Thanks for your report.
Closing as it's an installation report from debian installer version
which isn't supported anymore.
Feel free to test and report any issues against the current debian
installer release (Squeeze RC1) which supports more hardware and also
it's improved.


Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: