[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#606976: Kernel panic with Squeeze (AMD64) d-i beta 2

Taro Sato <taro@ap.smu.ca> writes:

> On Thu, Dec 16, 2010 at 12:27 PM, Ferenc Wagner <wferi@niif.hu> wrote:
>> Taro Sato <ubutsu@gmail.com> writes:
>>> I've tried d-i beta 2 on Dell XPS 630i.  I first tried creating a USB
>>> memory stick with the installer .iso on it (following a standard
>>> procedure); the install USB stick works on my other computer (Lenovo
>>> T410s).  However, on 630i it always fails at the beginning of the
>>> install process.  The message, when kernel panics, typically goes like
>>> this:
>>> ... (no apparent error messages thru this point) ...
>>> [0.597991] List of all partitions:
>>> [0.600310] No filesystem could mount root, tried:
>>> [0.602749] Kernel panic - not syncing: VFS: Unable to mount root fs on
>>> unknown-block(8,3)
>>> ... (call trace output after this) ...

Could you please also type in the call trace output what you get if you
remove the "quiet" parameter?  If this machine has a serial port, you
can also use that to capture the whole boot log, which would be
interesting as well (with a console=ttyS0,115200n8r or similar boot
parameter).  Unfortunately, serial ports are getting rare...

>> The above message indicates that no initramfs was loaded with the
>> kernel, or maybe it was corrupt.  If you didn't remove the "quiet"
>> parameter from the kernel command line, you'd see the message
>>    Initramfs unpacking failed: junk in compressed archive
>> in the latter case.
> I've never seen this message, though it might be possible that's
> something scrolls out of the screen when the boot process spews out
> the log message till the kernel panic.  I don't know how to capture
> it.

No, that message is printed even with "quiet", so you would have seen
it right above the panic line if it was present.

>> You could also try writing the mini.iso [...] to a pendrive
> I just tried the mini.iso on a USB stick and I see exactly the same
> kernel panic.
> (In order to get the system back up, I installed Lenny first, and then
> installed Squeeze from a hard disk partition which ended up very
> successful.  Wonder what the difference is.)

Do you mean that when you loaded the installer kernel and initrd by Grub
from your hard disk, everything went OK?  Most strange, again.  Long shot:
what if you add "edd=off" to your kernel command line (after "quiet")?

I don't think it would change anything, but you may want to test some
RC1-pre medium from http://cdimage.debian.org/cdimage/.squeeze_di_rc1/.

Reply to: