[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#238292: marked as done (The user had to umount the swap)

Your message dated Tue, 04 Jan 2011 23:29:15 +0000
with message-id <1294183755.2412.163.camel@eeepc.Belkin>
and subject line 
has caused the Debian Bug report #218765,
regarding The user had to umount the swap
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

218765: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=218765
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: I believe it was the i386 100MB CD from http://www.debian.org/devel/debian-installer/, downloaded about 24 Feb 2004 uname -a: 2.4.22-1-386 (having already upgraded at this time, I don't have the other details)
Date: about 2 March 2004
Method: Booted off the CD; configured networking, dual-boot with WinXP, after base install reconfigured sources.list to point to unstable and dist-upgraded

Machine: Dell Optiplex GX270
Processor: 2.20 GHz Celeron
Memory: 256MB
Root Device: 40 GB IDE /dev/hda (brand/model unknown)
Root Size/partition table:
Disk /dev/hda: 41.1 GB, 41110142976 bytes
255 heads, 63 sectors/track, 4998 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1        2550    20482843+   7  HPFS/NTFS WinXP
/dev/hda2            2551        4998    19663560    5  Extended
/dev/hda5 2551 3766 9767488+ c W95 FAT32 (LBA) /dos (for sharing between the two OSes)
/dev/hda6            3767        3790      192748+  83  Linux /
/dev/hda7            3791        3814      192748+  83  Linux /boot
/dev/hda8            3815        4179     2931831   83  Linux /usr
/dev/hda9            4180        4270      730926   83  Linux /var
/dev/hda10           4271        4732     3710983+  83  Linux /home
/dev/hda11           4733        4856      995998+  83  Linux /tmp
/dev/hda12           4857        4998     1140583+  82  Linux swap

Output of lspci:

00:00.0 Host bridge: Intel Corp. 82865G/PE/P Processor to I/O Controller (rev 02) 00:02.0 VGA compatible controller: Intel Corp. 82865G Integrated Graphics Device (rev 02)
00:1d.0 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.1 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.2 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.3 USB Controller: Intel Corp. 82801EB USB (rev 02)
00:1d.7 USB Controller: Intel Corp. 82801EB USB2 (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB/EB PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp. 82801EB LPC Interface Controller (rev 02)
00:1f.1 IDE interface: Intel Corp. 82801EB Ultra ATA Storage Controller (rev 02) 00:1f.2 IDE interface: Intel Corp. 82801EB Ultra ATA Storage Controller (rev 02)
00:1f.3 SMBus: Intel Corp. 82801EB SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp. 82801EB AC'97 Audio Controller (rev 02) 01:0c.0 Ethernet controller: Intel Corp. 82540EM Gigabit Ethernet Controller (rev 02)
Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [E]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


First, apologies for not taking better notes/remembering better/having this form in front of me when I did the install.

Second . . .

When mounting partitions, after I mounted the FAT32 partition on /dos, the swap partition was listed as already mounted. I don't remember the exact details, but it seems that I had to unmount swap and then remount, or maybe do the same to the /dos partition.

When it came time to install the boot loader, it did not offer me a chance to dual-boot, nor did it include the WinXP boot capability; I had to manually fix that later (which for me wasn't a problem, but for a newbie it would've been).

In the "Configure and Mount Partitions" screen, I was surprised to see that the nomenclature had changed from something like "/dev/hda" to "/dev/ide/host0/bus0/target-/lun0/part1". A help screen with what this terminology means, how it relates to the older terminology, and why the change, would go a long way toward making the installation friendlier.

When deciding on the type of file system to use (ext2, reiser, etc), it would be very helpful to have a help screen with a brief explanation of the different types, pros and cons, when I might want to use this vs that, should I mix types, etc.

I really like the "Go Back" button on several of the screens.

On the partitioning screen, it was not clear that some of my partitions would not be overwritten/reformatted; it would be very helpful if the screen marked such partitions with something like "won't be touched" or "leave as is", etc.

During the initialization, there needs to be some feedback; once I hit the "continue" button (or whatever it was), the next minute or few the computer just sat there, and I had no idea if the installation had hung, or if the partitions were being initialized, or what. If I had been the impatient type, especially a newbie coming from the world of Windows where reboots are expected, I might would've hit the reset button to "recover from the freeze-up".

I made a note about "what if I don't want to" in relation to installing LILO onto the hard disk. I don't remember the details, but I suspect I wasn't given a choice about installing LILO. That choice needs to be offered.

I have another note about "what does this long string mean '/dev/ide/host0.../disc'". I suspect that's another suggestion to have a help screen explaining the new nomenclature for dealing with drives.

Overall, the installer has a lot of promise, but the whole reason for it (as I understand it), is to make the process friendlier. In that vein, I offer the above comments.


--- End Message ---
--- Begin Message ---
Don't know when was fixed but doesn't happen with debian squeeze beta2.

Melhores cumprimentos/Best regards,

Miguel Figueiredo

--- End Message ---

Reply to: