[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#267923: marked as done (installation report)

Your message dated Wed, 08 Sep 2010 03:57:35 +0000
with message-id <E1OtBmx-0003tp-Qo@ravel.debian.org>
and subject line Closing old installation report #267923
has caused the Debian Bug report #267923,
regarding installation report
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

267923: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=267923
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports


Debian-installer-version: 18 Aug 2004, http://cdimage.debian.org/pub/cdimage-testing/daily/i386/current/sarge-i386-netinst.iso

uname -a: Linux <hostname> 2.6.7-1-386 #1 Thu Jul 8 05:08:04 EDT 2004 i686 GNU/Linux

Date: 18 Aug 2004 13:50

How did you install?
partition -> boot CD -> partition some more -> install base -> reboot -> base-config -> apt-get

What did you boot off?
CD burned from netinst image mentioned above

If network install, from where?


Machine: Desktop PC
Processor: Pentium 4
Memory: 1 GB PC133 RAM
Root Device: hda: 20 GB IDE HD, hdc: 10 GB HD, hdd: Liteon CD-RW
Root Size/partition table:

# fdisk -l /dev/hda /dev/hdc

Disk /dev/hda: 20.4 GB, 20496236544 bytes
255 heads, 63 sectors/track, 2491 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1         729     5855661   83  Linux
/dev/hda2             730        2491    14153265    5  Extended
/dev/hda5             730        1458     5855661   83  Linux
/dev/hda6            1459        1580      979933+  82  Linux swap
/dev/hda7            1581        2188     4883728+  83  Linux
/dev/hda8            2189        2285      779121   83  Linux
/dev/hda9            2370        2491      979933+  82  Linux swap
/dev/hda10           2286        2369      674698+  83  Linux

Partition table entries are not in disk order

Disk /dev/hdc: 10.2 GB, 10242892800 bytes
255 heads, 63 sectors/track, 1245 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

  Device Boot      Start         End      Blocks   Id  System
/dev/hdc1   *           1         365     2931831   83  Linux
/dev/hdc2             366        1245     7068600    5  Extended
/dev/hdc5             366        1123     6088603+  83  Linux
/dev/hdc6            1124        1245      979933+  82  Linux swap

# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hda1              5763616   2809624   2661212  52% /
tmpfs                   453780         0    453780   0% /dev/shm
/dev/hda5              5763616   1943336   3527500  36% /home
/dev/hda8               730120    464806    226358  68% /usr/local
/dev/hda10              632327    325223    273370  55% /opt
/dev/hdc1              2885780     32828   2823636   2% /bakup
/dev/hdc5              6087831    505153   5582678   9% /wienuser
/dev/hda7              4806904   3486876   1075844  77% /mnt/fedora

Note that on /dev/hda, all partitions except / were restored from backups of old system (sargified woody), and partitions on /dev/hdc were created after installation finished.

Output of lspci and lspci -n:
$ lspci
0000:00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 03) 0000:00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 12)
0000:00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 12)
0000:00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 12)
0000:00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 12)
0000:00:1f.3 SMBus: Intel Corp. 82801BA/BAM SMBus (rev 12)
0000:00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 12)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 12) 0000:01:00.0 VGA compatible controller: nVidia Corporation NV5M64 [RIVA TNT2 Model 64/Model 64 Pro] (rev 15) 0000:02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM Ethernet Controller (rev 03)
$ lspci -n
0000:00:00.0 0600: 8086:1a30 (rev 03)
0000:00:01.0 0604: 8086:1a31 (rev 03)
0000:00:1e.0 0604: 8086:244e (rev 12)
0000:00:1f.0 0601: 8086:2440 (rev 12)
0000:00:1f.1 0101: 8086:244b (rev 12)
0000:00:1f.2 0c03: 8086:2442 (rev 12)
0000:00:1f.3 0c05: 8086:2443 (rev 12)
0000:00:1f.4 0c03: 8086:2444 (rev 12)
0000:00:1f.5 0401: 8086:2445 (rev 12)
0000:01:00.0 0300: 10de:002d (rev 15)
0000:02:08.0 0200: 8086:2449 (rev 03)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [0]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Problem #1: HD booting installer failed

Booting off a hard disk partition as described in the installation guide did not work.

I placed initrd.gz and vmlinuz from ftp://mirror.aarnet.edu.au/debian/dists/testing/main/installer-i386/20040801/images/hd-media/2.6/ in an otherwise empty ext2 partition and set up lilo as per instructions at ftp://mirror.aarnet.edu.au/debian/dists/testing/main/installer-i386/20040801/doc/manual/en/ch05s01.html#boot-initrd

Boot hung with this final message:
Kernel panic: VFS: Unable to mount root fs on ram1

I tried increasing the size of the ramdisk in lilo, but it did not help. In the end I gave up and burnt the netist CD image.

Problem #2: base-config insists on using security.debian.org
-----------  + resulting mail setup stuff-ups

I am behind a proxy server, but I have direct access to selected sites, including the Debian mirror at mirror.aarnet.edu.au. To access other sites I need to supply a username and password and when I do so I get charged $$ for downloads (even if I download from sites I could access without going through the proxy server).

So, during base-config, I put the local mirrors in /etc/apt/sources.list and said no to the proxy server questions. At first base-config doing an apt-get update seemed to go fine, but then without even asking me off it goes looking for stuff at security.debian.org, which the proxy server will not allow.

After some minutes the failed wget's timed out and I was prompted about mail messages to root being redirected to normal user. I hastily picked the wrong thing I think. I wanted to send mail through an external smtp server to my usual email address, but base-config installed an smtp server on my PC instead.

Now when I rerun base-config, it exits with errors after the security.debian.org business, so I can't check what happened with the mail setup.

I would prefer if base-config respected my wishes and just go with what I put in /etc/apt/sources.list. Then it could ask me if I want it to fetch stuff from security.debian.org, or if I want to use a mirror, i.e., ftp://mirror.aarnet.edu.au/pub/debian-security.

Problem #3: missing 128 MB of RAM

Under debian I'm missing 128 MB of RAM! (I have 1 GB.) Under the otherwise rather buggy Fedora Core 2 I have all my RAM.

Sifting through output of dmesg I found:

Warning only 896MB will be used.
Use a HIGHMEM enabled kernel.
896MB LOWMEM available.

... and then
$ grep MEM /boot/config-2.6.7-1-386
# CONFIG_HIGHMEM4G is not set
# CONFIG_HIGHMEM64G is not set

$ grep MEM /mnt/fedora/boot/config-2.6.5-1.358
# CONFIG_HIGHMEM64G is not set

So I guess I'll have to recompile the kernel if I want the last 100 MB of my RAM. This is not something one expects to have to do after a fresh install.

Problem #4: hdparm version in database inconsistent with package

I guess this is really a post-post-install issue, but since having DMA turned on for hard disks and CD-ROMs is so essential I'll include it here. The version of hdparm on the database is inconsistent with the packages available. I had to download and install hdparm_5.5-2_i386.deb manually as apt-get will try to fetch the non-existent hdparm_5.5-4_i386.deb. This problem has been around for quite some time now.


Need some better package selection tools, especially for new users.
tasksel has become even more lame than it was in woody. How about options like development tools, tex, KDE, GNOME..., office?
The best thing about aptitude is the ascii minesweeper.
This doesn't worry me though. I'm happy to keep apt-getting what I want.

Last but not least, Thank You for a great OS!

Steven Homolya
School of Physics and Materials Engineering
Monash University, VIC 3800
Tel: +61 3 9905 3646
Fax: +61 3 9905 3637

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: