[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#267071: marked as done ([i386][20040818] Successful install and some comments)

Your message dated Wed, 08 Sep 2010 03:57:35 +0000
with message-id <E1OtBmx-0003sw-EY@ravel.debian.org>
and subject line Closing old installation report #267071
has caused the Debian Bug report #267071,
regarding [i386][20040818] Successful install and some comments
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

267071: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=267071
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: installation-reports

Debian-installer-version: 20040818 sarge-businesscard from daily images
uname -a: Linux tiamat1 2.6.7-1-686 #1 Thu Jul 8 05:36:53 EDT 2004 i686 GNU/Linux
Date: 8/19/2004 ~4pm
Method: Network installed using a businesscard image.  Base came from
	ftp.us.debian.org through our firewall.

Machine: IBM Thinkpad T41p
Processor: 1.7GHz Pentium M
Memory: 1GB
Root Device: IDE
Root Size/partition table: One partition for linux mounted on /

The number of cylinders for this disk is set to 155061.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., old versions of LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

Command (m for help): p

Disk /dev/hda: 80.0 GB, 80026361856 bytes
16 heads, 63 sectors/track, 155061 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1       40635    20480008+   7  HPFS/NTFS
/dev/hda2           40636      151005    55626480    f  W95 Ext'd (LBA)
/dev/hda3          151006      155055     2041200   82  Linux swap
/dev/hda5           40636      151005    55626448+  83  Linux

Output of lspci and lspci -n:

tiamat1:/home/jlquinn# lspci
0000:00:00.0 Host bridge: Intel Corp. 82855PM Processor to I/O Controller (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 82855PM Processor to AGP Controller (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01)
0000:00:1d.1 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01)
0000:00:1d.2 USB Controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01)
0000:00:1d.7 USB Controller: Intel Corp. 82801DB/DBM (ICH4/ICH4-M) USB 2.0 EHCI Controller (rev 01)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 81)
0000:00:1f.0 ISA bridge: Intel Corp. 82801DBM LPC Interface Controller (rev 01)
0000:00:1f.1 IDE interface: Intel Corp. 82801DBM (ICH4) Ultra ATA Storage Controller (rev 01)
0000:00:1f.3 SMBus: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Audio Controller (rev 01)
0000:00:1f.6 Modem: Intel Corp. 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) AC'97 Modem Controller (rev 01)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc M10 NT [FireGL Mobility T2] (rev 80)
0000:02:00.0 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
0000:02:00.1 CardBus bridge: Texas Instruments PCI4520 PC card Cardbus Controller (rev 01)
0000:02:01.0 Ethernet controller: Intel Corp. 82540EP Gigabit Ethernet Controller (Mobile) (rev 03)
0000:02:02.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

tiamat1:/home/jlquinn# lspci -n
0000:00:00.0 0600: 8086:3340 (rev 03)
0000:00:01.0 0604: 8086:3341 (rev 03)
0000:00:1d.0 0c03: 8086:24c2 (rev 01)
0000:00:1d.1 0c03: 8086:24c4 (rev 01)
0000:00:1d.2 0c03: 8086:24c7 (rev 01)
0000:00:1d.7 0c03: 8086:24cd (rev 01)
0000:00:1e.0 0604: 8086:2448 (rev 81)
0000:00:1f.0 0601: 8086:24cc (rev 01)
0000:00:1f.1 0101: 8086:24ca (rev 01)
0000:00:1f.3 0c05: 8086:24c3 (rev 01)
0000:00:1f.5 0401: 8086:24c5 (rev 01)
0000:00:1f.6 0703: 8086:24c6 (rev 01)
0000:01:00.0 0300: 1002:4e54 (rev 80)
0000:02:00.0 0607: 104c:ac46 (rev 01)
0000:02:00.1 0607: 104c:ac46 (rev 01)
0000:02:01.0 0200: 8086:101e (rev 03)
0000:02:02.0 0200: 168c:1014 (rev 01)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [E]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


* At start, network cable was unplugged.

I get message telling me to enter an IP.  I was expecting it to use DHCP and
didn't see why it wanted a static address.

I should have gotten an error about not being able to get on the network,
i.e. cable was unplugged.

plugging in the cable, going back, then forward, fixes the problem.

* After being presented with a dhcp hostname, I tried to use Alt-backspace to
  delete the whole word.  This instead gave me a bailout menu to retry dhcp or
  configure manually.  Not what I expected.

go back then forward gets me back where i was.

* Installer doesn't allow me to manually specify the apt mirror.

We have a debian mirror inside our firewall.  It would be good to have allowed
us to point at it directly instead of hitting an external mirror.  Granted
only for the base system, but still it was unneeded bandwidth.


At this point, the base system is installed and working.  Continuing to
extended install.

I selected default desktop install.

* Configuring xserver-xfree86

I was asked for the desired xserver driver.  This is a T41 with an ATI
chipset.  This should have been autodetected.

* mouse autodetection should happen by default on a modern piece of hardware.
At the very least, the question should default to yes.

* same with monitor autodetection.  The laptop has a built in lcd.

* I was asked if the monitor is an LCD, after telling it to autodetect.  This
  should have been figured out automatically.

* I received the screen on choosing simple, medium, or advanced despite the
  fact that it says the option is disabled for LCD panels and I have an LCD

* Ah.  The previous warning is that LCD disables "simple".  Why?  If anything,
  I'd think LCD's would be easier to autodetect the dimensions and such.

  it and have no way of finding out!

Medium would be a problem because the resolution is 1400x1050, not a standard
VESA size.

I'll be very surprised if I get a working X display...

The other packages are now unpacking.

* X did come up, but only with 800x600.  After editing the xconfig file and
  removing the explicit resolutions, I was able to get full 1400x1050.  Great!

* Installer seems to have brought the machine up under ACPI.

Battery monitoring is not working.
Suspend when I close the lid is not working.
Display to external monitor is not working.

On the T30, the second two did not work with ACPI and I had to switch to APM
to get them back.  I'll see if this is true with the T41p as well.

* The machine has an atheros wireless card.  Wireless isn't working.  Please
  consider adding a working driver for the card, even if it's in non-free.

* No 3D, unfortunately.  I know this is a function of lack of support in
  XFree, but disappointing nonetheless.

* I've seen a couple of lockups with no information.  I suspect the video, but
  don't know how to confirm.

--- End Message ---
--- Begin Message ---
We are closing this installation report for one of the following
- it was reported with a pre-lenny version of Debian
- indications in the installation report give the feeling that
  the reported problem waslying in another software, unrelated to
  D-I, which we can't easily identify.
- indications in the installation report suggest that it may have been
  fixed in a more recent version of a D-I component
- it was successful and we forgot closing it..:-)
- it has no information we consider useful

The D-I team is currently in the process of cleaning out the old spool
of installation reports that haven't bene processed yet. 

In case you think that the problem you reported has chances to be
still present, please reiterate your installation test with
a more recent image of D-I, if you're in position of doing this.

You'll find daily builds at
http://www.debian.org/devel/debian-installer. We recommend you choose
the netboot image, in the "daily builds section", then choose to
install "squeeze" when prompted.

If some problems are found, please report them with a new bug sent
against installation-reports.

Many thanks for your understanding and your help improving Debian,
past and present.

--- End Message ---

Reply to: