[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#511842: installation-reports: Pre-existing LVM partition crashes the partitioner

severity 511842 normal
tags 511842 unreproducible

On Wednesday 14 January 2009, Pyotr Berezhkov wrote:
> Comments/Problems:
> The installer's partitioner appears to be unable to handle the
> situation where an LVM partition already exists on one of the
> computer's disks at the time of install.  Here's the experience I had:

I've tried that too and had absolutely no problems, neither using guided 
partitioning for the second disk, nor using manual partitioning. The LVs 
already present on the first disk were correctly detected and I could set 
up LVM VG and LVs on the second disk alongside them without any problems.

I have not tried encrypted LVM, but I don't see how that would make a 

>   * Leaving the first install untouched, I attempted a second install
>     analogous to the first one, only on the second disk (sdb1, 6GB,
>     VG "lenny", boot/crypt root LVs).  This is where the installer
>     crashed.

"This is where is crashed" is not very specific. Please describe the 
excact steps you performed after starting the partitioner and indicate 
when exactly the crash happened.

>     I rebooted and repeated 4 times to verify, every time 
>     with the same results.  I've included relevant output from two of
>     the crashes in the attached tarball.  Note that the new LVs were
>     successfully created, judging from the contents of /dev/mapper:

I don't see any crash in the first syslog, at most a "hang" (from looking 
at the output from 'ps'. And I think that hang may already be fixed in 
current daily built images, although it happened in a very specific 
situation that I do not find in your description.

To trace this issue correctly we'll need two things (if you can still 
reproduce it):
- a detailed and exact description of your actions from the start of
- full debug output from partman; you can get that by adding a line
  'set -x' in /lib/partman/lib/base.sh

One cause of the problem could be inconsistent traces of LVM metadata on 
your disks from previous installs.


Reply to: