[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#511842: installation-reports: Pre-existing LVM partition crashes the partitioner

Package: installation-reports
Severity: important

-- Package-specific info:

Boot method: USB stick
Image version: Lenny RC1 amd64 netinst (http://cdimage.debian.org/cdimage/lenny_di_rc1/amd64/iso-cd/debian-testing-amd64-netinst.iso)
Date: <Date and time of the install>

Machine: Athlon X2 5200+ desktop

Disk /dev/sda: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x000246ae

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *           1         612     4915858+  8e  Linux LVM
/dev/sda3             613       19457   151372462+   5  Extended
/dev/sda5             613        1221     4891761   83  Linux
/dev/sda6            1222        3046    14659281   83  Linux
/dev/sda7            3047        3169      987966   83  Linux
/dev/sda8            3293        3415      987966   83  Linux
/dev/sda9            3416        3538      987966   83  Linux
/dev/sda10           3539        3661      987966   83  Linux
/dev/sda11           3662        3784      987966   83  Linux
/dev/sda12           3785        4393     4891761   83  Linux
/dev/sda13           4394        5610     9775521   83  Linux
/dev/sda14           5611        6827     9775521   83  Linux
/dev/sda15           6828       19457   101450443+  83  Linux

Disk /dev/sdb: 160.0 GB, 160041885696 bytes
255 heads, 63 sectors/track, 19457 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0x00034287

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1         732     5879758+  8e  Linux LVM
/dev/sdb3             733       19457   150408562+  83  Linux

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Install base system:    [O]
Clock/timezone setup:   [O]
User/password setup:    [O]
Install tasks:          [O]
Install boot loader:    [O]
Overall install:        [O]


The installer's partitioner appears to be unable to handle the situation
where an LVM partition already exists on one of the computer's disks at
the time of install.  Here's the experience I had:

  * With my first install (on a system with no LVM partitions), the
	partitioner worked fine with my two SATA disks connected.  I created
	a VG "sid" on the first disk (/dev/sda1, 5GB) with boot and
	root_crypt LVs, and sucessfully completed the install.

  * Leaving the first install untouched, I attempted a second install
    analogous to the first one, only on the second disk (sdb1, 6GB,
    VG "lenny", boot/crypt root LVs).  This is where the installer
    crashed.   I rebooted and repeated 4 times to verify, every time
    with the same results.  I've included relevant output from two of
    the crashes in the attached tarball.  Note that the new LVs were
    successfully created, judging from the contents of /dev/mapper:

        253,   3 Jan 11 20:24 /dev/mapper/lenny-root
        253,   2 Jan 11 20:23 /dev/mapper/lenny-boot
        253,   1 Jan 11 20:20 /dev/mapper/sid-root
        253,   0 Jan 11 20:20 /dev/mapper/sid-boot
         10,  60 Jan 11 20:20 /dev/mapper/control

  * Suspecting that the presence of a pre-existing LVM volume
	group was crashing the installer, I experimented by deleting VG
	"lenny" on disk 2, moved VG "sid" to from sda to sdb1, changed the
	partition ID of /dev/sda1 back to "Linux" and rebooted into the
	installer.  This time the installer crashed right away when I got to
	the "Partitioning" option; I wasn't even able to switch VTs to save

    So then I just physically disconnected disk 2, rebooted into the
    installer and did an install analogous to my first one.  As I
	expected, everything went perfectly this time, since there were no
	visible LVM partitions on disk now.

    My conclusion: the presence of any existing LVM volume group crashes
    the partitioner.  This is a serious problem for those who are already
    using LVM at the time of the install.

Other than this problem, the installer worked wonderfully.  My respect
to the developers.  There were just a few minor quibbles.  For example,
the search for an install image is painfully slow if you have lots of
partitions and/or disks - they could be scanned more intelligently and
quickly, ignoring any partitions without filesystems, encrypted
partitions, etc.  Also, the pppoe setup might prompt the user for the
network interface connected to the Internet, instead of just blindly
probing for it.


-- System Information:
Debian Release: 5.0
  APT prefers testing
  APT policy: (500, 'testing')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.26-1 (SMP w/2 CPU cores; PREEMPT)
Locale: LANG=ru_RU.UTF8, LC_CTYPE=ru_RU.UTF8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/bash

Attachment: lenny-installer-partitioner-crash.tgz
Description: GNU Unix tar archive

Reply to: