[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Installation report HP-715/64 (HIL)

On Tue, Dec 23, 2008 at 12:35:51PM +0100, Helge Deller wrote:
> Moritz Muehlenhoff wrote:
> >> The boot-kernel (2.6.18) does not detect this keyboard on the HIL bus.
> >> It seems the needed .config values are not set when it was built.
> >> To solve this problem, the boot kernel needs the "CONFIG_KEYBOARD_HIL_OLD=y" option set.
> >> Additionally, all other "HIL" options should be disabled (see below).
> >> With those options, the HIL keyboard should work. HIL-Mouse will not be available, but it's not needed either for the installation process.
> >> In general, all newer HIL drivers do not work at all, so defaulting back to the old driver should be ok.
> > 
> > The Lenny kernel sets CONFIG_KEYBOARD_HIL_OLD=m, does this still apply?
> Moritz, thanks for bringing this up again. I nearly forgot it!
> I just tried the netboot image dated 30-10-08 from
> http://ftp.nl.debian.org/debian/dists/testing/main/installer-hppa/current/images/netboot/2.6/.
> Currently the debian installer boots up nicely, but the keyboard is not
> functional at all (on machines with HIL keyboard).
> My tests with booting via serial console shows, that all what needs to
> be done to get those keyboards working now is, to run a
> "modprobe hilkbd"
> at startup.
> Is it possible that someone from the debian-installer teams add this
> "modprobe hilkbd" somewhere to the bootup process? This modprobe should
> also be carried over to the installed system afterwards.
> I'm willing to test any temporary images (preferably netboot images) as
> soon as possible.

[Forwarding to debian-boot@lists.debian.org]

Can that be considered for rc2?


Reply to: