[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#509379: firmware not found on virtual floppy or virtual CDROM

Christian Perrier wrote:
reassign 509379 hw-detect

Quoting Daniel Pocock (daniel@pocock.com.au):
Package: debian-installer

Installing lenny amd64 on a Dell M600 blade server using PXE/netboot method.

bnx2 firmware required for network access.

Installer prompts for a floppy or USB device.

I attempted to mount an ext3 formatted floppy image, and an ISO CDROM

You attempted to *mount*?

What exactly did you try to do apart from putting the firmware file (or
deb package for the record) on a removable medium and hit Enter when
prompted for firmware?
My explanation wasn't thorough enough:

- I saw the prompt to insert the floppy or USB disk

- I used the iDRAC (Dell's iLO solution) to enable the virtual floppy

- I pressed the OK button in d-i, telling it to search for the removable media

- d-i told me no removable media found (I can't remember the exact message I saw)

- I then opened a shell (Alt-F2) and tried to manually locate the firmware
If you tried some manual actions in a shell in VT2, that might be the
cause of the problem.

I only did that after getting errors from d-i. I wanted to know if the removable media was recognised by the installer's kernel. In this case, it was recognised by the kernel as a SCSI device.
If you just did what's instructed (put the files on a floppy, USB
stick or CD, then hit Enter), then something went wrong, really..:-)

In such case, after seeing the error message that the media can't be
located, could you switch to VT2 (Alt+F2), then check if something is
mounted on /media...
I will test this on a similar box, as this one has already gone live. It may not happen until January now. Thanks for taking the time to look into this issue, I hope the detail I'm providing is useful.



Reply to: