[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#474698: partman-base: Inconsistent output if sector size != 512 bytes

Frans Pop <elendil@planet.nl> writes:

> (No need to CC me on replies to the BR.)
> On Tuesday 08 April 2008, Ferenc Wagner wrote:
>> I could go on to replace PED_SECTOR_SIZE_DEFAULT with dev->sector_size
>> throughout partman-base/parted_server.c, but I'm getting suspicious.
>> Isn't there a good reason for this state of affairs?
> Looks like this could possibly be a bug introduced by revision r37468 [1], 
> which changed PED_SECTOR_SIZE to PED_SECTOR_SIZE_DEFAULT (partman-base 84). 
> Looks like that change was made for compatibility with libparted 1.7.
> Whether changing it to dev->sector_size is correct depends of course on what 
> the actual definition of PED_SECTOR_SIZE was in prior libparted versions.
> It could also be that the problem has always been there and that the use of 
> PED_SECTOR_SIZE was always not correct (though maybe only in some places).
> This certainly needs to be checked very carefully. A good start could be to 
> check whether the Sarge installer also has the bug as that has older 
> versions of libparted and partman-base.
> Otavio: you did that change; any comments?

I'll look into it. Nothing from the top of my head.

        O T A V I O    S A L V A D O R
 E-mail: otavio@debian.org      UIN: 5906116
 GNU/Linux User: 239058     GPG ID: 49A5F855
 Home Page: http://otavio.ossystems.com.br
"Microsoft sells you Windows ... Linux gives
 you the whole house."

Reply to: