[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#474737: Etch netboot installer does not detect ide harddisk

On Monday 07 April 2008, markus.mbox@gmx.de wrote:
> Comments/Problems:
> The IDE hard disk is not detected. The installer then wants to create
> partitions on the floppy.

I have used vmware myself extensively before the release of Etch and it 
always worked for me. At some point I ran into kernel incompatibilities 
(vmware 5.2 with 2.6.24 kernel) and eventually switched to VirtualBox.

So basically I have no idea how compatible current vmware versions are with 
the Etch kernel (2.6.18), or even with current testing/unstable kernels.

Problem seems to be that the piix module is not getting loaded, which is 
needed for your IDE controller.
What happens if you try to modprobe that manually?

> This failure happens on a virtual machine and on real hardware also.

Please file a separate bug report for the real hardware, with logs attached.

> Newer versions of kernel and initrd don't work with
> debian-40r3-i386-DVD-1.iso (module version mismatch).

That is correct. You could try a "daily built" businesscard or netinst image 
[1], just to see if that does detect the disks. That has a 2.6.24 kernel.


[1] http://www.debian.org/devel/debian-installer/

Reply to: