[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#463866: marked as done (Missing ptys in lenny /target/)

Your message dated Sat, 16 Feb 2008 13:02:02 +0000
with message-id <E1JQMg6-0003Yg-KL@ries.debian.org>
and subject line Bug#463866: fixed in debian-installer-utils 1.55
has caused the Debian Bug report #463866,
regarding Missing ptys in lenny /target/
to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what this
message is talking about, this may indicate a serious mail system
misconfiguration somewhere. Please contact owner@bugs.debian.org

463866: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=463866
Debian Bug Tracking System
Contact owner@bugs.debian.org with problems
--- Begin Message ---
Package: debian-installer
Version: n/a; 2008-02-03

When using the d-i image to install Debian Edu/Lenny, I ran into a
problem with missing ptys.  We install debian-edu-config very early in
the installation, and this will try to enable debian-edu-etc-svk,
which need to use expect to initialize the svk repository while we
wait for a fix for #435786 scheduled for version 2.0.1-1.

The expect call fail because /dev/pts/ is not mounted in /target/.
This used to work in etch, because /dev/ was populated with a lot of
pseudo ttys.  Now, /dev/ do not have them, and the devpts file system
mounted on /dev/pts/ is needed to get expect working.

Should /dev/pts/ be mounted in /target/?  I worked around it by
mounting it in the script running expect, like this:

    if [ ! -f /dev/pts/0 ] ; then
        if mount -t devpts devpts -o noexec,nosuid,gid=5,mode=620 /dev/pts ; then
    if [ yes = "$mountedpts" ] ; then
        umount /dev/pts

Perhaps this code should be in in-target instead?

Happy hacking,
Petter Reinholdtsen

--- End Message ---
--- Begin Message ---
Source: debian-installer-utils
Source-Version: 1.55

We believe that the bug you reported is fixed in the latest version of
debian-installer-utils, which is due to be installed in the Debian FTP archive:

  to pool/main/d/debian-installer-utils/debian-installer-utils_1.55.dsc
  to pool/main/d/debian-installer-utils/debian-installer-utils_1.55.tar.gz
  to pool/main/d/debian-installer-utils/di-utils-exit-installer_1.55_all.udeb
  to pool/main/d/debian-installer-utils/di-utils-mapdevfs_1.55_amd64.udeb
  to pool/main/d/debian-installer-utils/di-utils-reboot_1.55_all.udeb
  to pool/main/d/debian-installer-utils/di-utils-shell_1.55_all.udeb
  to pool/main/d/debian-installer-utils/di-utils-terminfo_1.55_all.udeb
  to pool/main/d/debian-installer-utils/di-utils_1.55_amd64.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 463866@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Frans Pop <fjp@debian.org> (supplier of updated debian-installer-utils package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Sat, 16 Feb 2008 13:48:36 +0100
Source: debian-installer-utils
Binary: di-utils-shell di-utils-reboot di-utils-exit-installer di-utils di-utils-mapdevfs di-utils-terminfo
Architecture: source all amd64
Version: 1.55
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Frans Pop <fjp@debian.org>
 di-utils   - Miscellaneous utilities for the debian installer (udeb)
 di-utils-exit-installer - Exit installer (udeb)
 di-utils-mapdevfs - mapdevfs utility for the debian installer (udeb)
 di-utils-reboot - Reboot (udeb)
 di-utils-shell - Execute a shell (udeb)
 di-utils-terminfo - Terminfo entries needed by newt/slang in debian installer (udeb)
Closes: 463866
 debian-installer-utils (1.55) unstable; urgency=low
   * chroot-setup.sh: also mount /dev/pts to avoid errors like:
     Can not write log, openpty() failed (/dev/pts not mounted?)
     Thanks to Petter Reinholdtsen for the patch. Closes: #463866.
 a610fdaf325cc88addb14c4423cf3fd9 1041 debian-installer standard debian-installer-utils_1.55.dsc
 6c14080c7cba6e47c5109741d2f04964 68049 debian-installer standard debian-installer-utils_1.55.tar.gz
 984efdeef696b97debbaf68bff9933a9 17624 debian-installer standard di-utils-shell_1.55_all.udeb
 040899f2f138f1209bef4d84f4505af5 7910 debian-installer standard di-utils-reboot_1.55_all.udeb
 9e8d06d5a8b6c9360666f8d574fc1162 2764 debian-installer extra di-utils-exit-installer_1.55_all.udeb
 b9ccd0feea0a097f7b548265948ae92d 2416 debian-installer standard di-utils-terminfo_1.55_all.udeb
 c1d0589a92f5d12972bb867b29a2ed4b 10434 debian-installer standard di-utils_1.55_amd64.udeb
 b74167f5595c953a358843eeaa12f8ab 2366 debian-installer standard di-utils-mapdevfs_1.55_amd64.udeb
Package-Type: udeb

Version: GnuPG v1.4.6 (GNU/Linux)


--- End Message ---

Reply to: