[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#463866: Missing ptys in lenny /target/

Package: debian-installer
Version: n/a; 2008-02-03

When using the d-i image to install Debian Edu/Lenny, I ran into a
problem with missing ptys.  We install debian-edu-config very early in
the installation, and this will try to enable debian-edu-etc-svk,
which need to use expect to initialize the svk repository while we
wait for a fix for #435786 scheduled for version 2.0.1-1.

The expect call fail because /dev/pts/ is not mounted in /target/.
This used to work in etch, because /dev/ was populated with a lot of
pseudo ttys.  Now, /dev/ do not have them, and the devpts file system
mounted on /dev/pts/ is needed to get expect working.

Should /dev/pts/ be mounted in /target/?  I worked around it by
mounting it in the script running expect, like this:

    if [ ! -f /dev/pts/0 ] ; then
        if mount -t devpts devpts -o noexec,nosuid,gid=5,mode=620 /dev/pts ; then
    if [ yes = "$mountedpts" ] ; then
        umount /dev/pts

Perhaps this code should be in in-target instead?

Happy hacking,
Petter Reinholdtsen

Reply to: