[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#418590: main-menu: Segfault during automatic install on AMD64

reassign 418590 preseed 1.28

On Tuesday 10 April 2007 23:08, Olaf van der Spek wrote:
> On 4/10/07, Frans Pop <elendil@planet.nl> wrote:
> > If that does not fix it, please try building up your preconfiguration
> > file line by line until you find what causes the segfault.
> The cause is: d-i clock-setup/utc boolean false

I have just tried to reproduce this on my own amd64 system, but cannot.
I have tried both with just the clock-setup line and with your original 
preseed file (but without the partman lines), but in both cases the 
preconfiguration file is loaded correctly.

Reassigning to preseed as it is doubtful the issue is in clock-setup 
itself and it will be easier to find under preseed.

There was someone else who reported the same issue on IRC, but if we 
cannot reproduce it, we will need you (or someone else) who can to debug 

To try to trace this I would suggest the following:
- boot with 'install url=http://<full-url-to-preseed-file>'
- at the first dialog, switch to VT2
- edit /var/lib/dpkg/info/network-preseed.postinst and add a 'set -x'
- continue the installation untill the problem occurs
- find some way to get the syslog off the system

The last may be tricky. You could try booting with BOOT_DEBUG=3 and 
editing /etc/inittab so the debian-installer program does not 
automatically respawn.
If you add modules=openssh-client-udeb at the boot prompt, you will be 
able to run scp from a shell.


Reply to: