[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#422255: Installing 4.0r0 etch with guided LVM encryption install and JFS fails (EXT3 is ok) in OS-X virtual machine

Package: installation-reports

Boot method: net-install
Image version: http://cdimage.debian.org/debian-cd/4.0_r0/i386/iso-cd/debian-40r0-i386-netinst.iso
Date: 2006-05-04

Machine: Virtual machine under OS-X 10.4 IMac Intel running Parallels
Desktop for Mac build 3188 March 7, 2007
Processor: Core 2 Duo 2+ Ghz, possibly only one core in virtual machine.
Memory: 2GB physical, 96MB virtual
Partitions: errh, default full partion hda1 something as per Paralles
emulation, 5GB

Output of lspci -nn and lspci -vnn: ??

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot:           [O]
Detect network card:    [O]
Configure network:      [O] (but seem other problem of other install
described below)
Detect CD:              [O] (virtual drive, mounted ISO image)
Load installer modules: [ ]
Detect hard drives:     [ ]
Partition hard drives:  [ ]
Install base system:    [E]
Clock/timezone setup:   [O]
User/password setup:    [ ]
Install tasks:          [ ]
Install boot loader:    [ ]
Overall install:        [E]


an installation bug report related to JFS and LUKS encrypted volumes.

Disclaimer: I am new to Debian and have spent more time on FreeBSD
(Etch is really nice! Ubuntu runs much slower with Gnome, and Ubuntu
randomly quits applications when memory is low.)

I have successfully installed several Debian Etch 4.0r0 i386 images as
virtual machines under OS-X 10.4 with Parallels, but here is a
configuration that fails:

96MB RAM, 5GB disk virtual machine bridged ethernet (hosed on 2Ghz
Core 2 Duo 2GB RAM, IMac OS-X Tiger 10.4) netinstall of Debian Edge
4.0r0 i386:

Guided LVM encryption where I change ext3 root filesystem to jfs.
The entire disk (5GB) is chosen.
After entering encryption password, root password and user password,
the system starts installing the base system.
After 20-33% the system stops progressing, for example while installing bash.
This is reproducible - but freeze doesn't happen exactly the same
place each time, hence 20-33%. It could be progress would happen
since it also pauses for shorter periods before 20%.

I then tried an install just using defaults all the way, that is, keep
ext3 instead of jfs. This works: Installation progresses all the way
through reboot and user login using the same 96MB/5GB configuration
(just base system, no desktop chosen).

Minor issue - network not starting automatically:
This could simply be the way Debian works by default allowing the user
to harden the system, but it caused my quite some frustration:
An earlier desktop install with 30GB disk and about 512MB RAM
progressed fine using businesscard (or netinstall, don't recall).
After loggin in as user in the new system, the network was dead
(worked fine during net install). Eventually I found the network icon
on the desktop and simply enabled the network. Before that I tried
various config scripts as described on the internet to no avail, but
then I'm no expert here. Strange though, since the network install
went fine. Parallels is using a slightly tricky laptop pcmcia network
emulation, as I recall.

Another problem - 64bit not launching X-Windows on OS-X 10.4 with
VMWare Fusion Beta 2:
I tried the 64bit install of Edge on VM Ware Fusion on OS-X. Note that
Paralles can only host 32 bit guest OS, while Fusion hosts 64-bit
guests. In this 64-bit installation, startx completely fails. I tried
to follow advise on the internet but failed on getting X started - no
device available or something like that. Ubuntu seemed to install fine
on Fusion, but don't recall exactly what version. Other than that, the
64-bit system seems to be running fine.


Reply to: