[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#416526: installation-report: semi-successful desktop install



-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Eddy Petrișor wrote:
> Steve Langasek wrote:
>> On Wed, Mar 28, 2007 at 08:45:44PM +0300, Eddy Petrior wrote:
>>> Network Manager was installed although only the desktop task was
>>> selected. This is broken since on a desktop it links the operation of
>>> setting up the network to an X application. Running
>>> /etc/init.d/networking restart had no effect since Network Manager
>>> "takes care" not to allow that script to do anything.
>> How does it do this?  There's nothing in the network-manager package's
>> maintainer scripts that would do this.
> 
>>> I haven't tested, but that would mean that I can't start the network
>>> unless I can start X
>> Um, so you've filed a serious bug without testing that anything has actually
>> broken?
> 
> No, you misunderstood.
> 
> These don't work (according to /usr/share/doc/README.Debian, only
> for interfaces marked auto and using dhcp):
> 
> /etc/init.d/networking restart
> 
> /etc/init.d/networking start
> 
> until you log in and enable the network interface.
> 
> 
> 
> I meant that I haven't tested right out the box from a text console,
> before starting any X session, but the commands above did not work
> from X until NM fiddled with it.
> 
> I have tested this after logging once and leaving the network
> configuration in an unconfigured state (according to NM); in this
> case, too the init script didn't work.
> 
> 
> 
> The only case where the init script worked was when I enabled the
> interface from NM and *then* it worked, even if I logged out of the
> X session. This would work until NM disables/deconfigures(/whatever
> is appropriate term would be according to NM) the card, when the
> init script, again, has no effect.

I have added a dummy pre-up hook to the network interface, after
reading this text in the readme:

2.)
auto wlan0
iface wlan0 inet dhcp
        wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
- -> This devices is *not* managed by NM because it has additional
options.

I have restarted the system, and indeed, NM stopped managing it.

This could be a work around for this issue, but needs to be done in
d-i to make NM ignore the interface.

- --
Regards,
EddyP
=============================================
"Imagination is more important than knowledge" A.Einstein
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFGCv/AY8Chqv3NRNoRAjFpAJ44CDt/M1aE3QUQ8vBVvO6AXa8AUgCfSPFm
jmfeO9GgBC13FaV2BI1mUTw=
=liSG
-----END PGP SIGNATURE-----



Reply to: