[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#416526: installation-report: semi-successful desktop install

On Thu, Mar 29, 2007 at 02:23:27AM +0300, Eddy Petrișor wrote:

> Steve Langasek wrote:
> > On Wed, Mar 28, 2007 at 08:45:44PM +0300, Eddy Petrișor wrote:
> >> Network Manager was installed although only the desktop task was
> >> selected. This is broken since on a desktop it links the operation of
> >> setting up the network to an X application. Running
> >> /etc/init.d/networking restart had no effect since Network Manager
> >> "takes care" not to allow that script to do anything.

> > How does it do this?  There's nothing in the network-manager package's
> > maintainer scripts that would do this.

> >> I haven't tested, but that would mean that I can't start the network
> >> unless I can start X

> > Um, so you've filed a serious bug without testing that anything has actually
> > broken?

> No, you misunderstood.

> These don't work (according to /usr/share/doc/README.Debian, only
> for interfaces marked auto and using dhcp):

> /etc/init.d/networking restart

> /etc/init.d/networking start

> until you log in and enable the network interface.

Yes, and I asked what the *mechanism* was that prevented this.  From the

 Configuration of wireless and ethernet interfaces
 Only devices that are *not* listed in /etc/network/interfaces or which have
 been configured "auto" and "dhcp" (with no other options) are managed by NM.

But I don't see anything in the package that stops ifupdown from managing
these devices normally; the implication seems to be that NM will provide
/additional/ management capabilities for such devices.

> I meant that I haven't tested right out the box from a text console,
> before starting any X session, but the commands above did not work
> from X until NM fiddled with it.

Please explain what "did not work" means.  What changes did you make that
did not take effect?  Are you sure they didn't take effect, only to be
immediately overridden by NM?  (The answer to this last probably doesn't
affect the severity of the bug, but may point to the solution.)

> The only case where the init script worked was when I enabled the
> interface from NM and *then* it worked, even if I logged out of the
> X session. This would work until NM disables/deconfigures(/whatever
> is appropriate term would be according to NM) the card, when the
> init script, again, has no effect.

Ok, still not sure what it means for this to not work.  NM provides no hooks
that prevent ifupdown from doing its job.

Steve Langasek                   Give me a lever long enough and a Free OS
Debian Developer                   to set it on, and I can move the world.
vorlon@debian.org                                   http://www.debian.org/

Reply to: