[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#407460: USB ethernet interface renamed after installation on NSLU2 which causes the system to be inaccessible

On 2/25/07, Gordon Farquharson <gordonfarquharson@gmail.com> wrote:

How about the following idea for a quick and simple workaround to this
problem (it is based on something Steve suggested earlier in the

Include the ixp4xx NPE driver modules in both the official and
unofficial installer images and modify oldsys-preseed with the patch

I have tested the installer (revision 45431) both with and without the
NPE-B microcode and everything worked fine on my setup. I also tested
the case where the user may have both a USB to Ethernet adapter and
the NPE-B microcode, and everything worked.

For these tests, I told the installer to use packages from unstable to
work around #412572 because the fix hadn't hit testing by the time I
started yesterday and I was too lazy to recompile apex with a
different kernel command line.

All my tests have been using a static IP address which is configured
in the NSLU2 flash. I should probably try a DHCP served address just
to make sure that it doesn't change anything.


Gordon Farquharson

Reply to: