[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#410596: [Fwd: (process:number) INFO: kbd-mode: setting console mode to Unicode (UTF-8)]

Steve Langasek wrote:
On Fri, Feb 16, 2007 at 04:51:55PM +0100, Pablo Ripolles wrote:

recently i've submitted an installation-report associated to a failed etch installation (CD netinst method) on an AlphaStation 500/266. this post is mainly because i suspect that it might be an alpha related bug and because it was my first time reporting such problem. now, has anyone in the alpha port community recently tried to install etch? perhaps with a similar system as mine? i've no idea why this happened and i'd like to be able to install etch in its final version. i'm afraid that this bug report passes unnoticed, should i report it otherwise? here is a link of the archived report:

I've certainly tested installing etch on alpha recently, but not on a
machine requiring low memory mode.  I have no idea what the minimum memory
requirements for the installer might be on alpha.
well, it seems that "in theory" the minimum memory requirements are 64MB (http://d-i.alioth.debian.org/manual/en.alpha/ch03s04.html). obviously once installed, it might be striped down to an even lower requirement. as you can see my alpha system has got these 64MB.
no big problem so far, however when i push it through "Detect network hardware", the logging console (Alt-F4) shows the kernel killing several processes associated
with the message "Out of Memory"

Yes, that pretty much says it all.
yes, i guess...
I haven't looked at the low-memory mode menu in quite some time.  Do you
have the option at this point to mount swap space?  That's the only way
you're going to get enough virtual memory to be able to continue the install
of etch;
when i boot using the option "priority=low" i have access to a reduced menu. to have access to the augmented menu where the disk options are, i need to execute first "Detect and mount CD-ROM" and second "Load installer components from CD". in the former entry i have the option to exclude a number of unnecessary modules from being loaded which i do. in these new menu is where the entries referring to "Detect disks" and then "Partition disks" are. well, at this point, any thing i do, any entry i execute (obviously including the disks related) fails, it just doesn't fit in memory! therefore i cannot even mount swap space, i cannot install etch in any way! or which are my left options?
 there's certainly no way that the installer's memory requirements
on alpha are going to be lowered for etch.
i see it this way. it's true that 64MB of memory is nowadays very little. i understand that every new version has got higher requirements than previous ones (3.1 worked great!) . but: -given the fact that it's said that 64MB is enough, then it should be enough. -given the fact that alpha is an almost extinguished architecture and that it is (quite!) difficult to get working memory upgrades for those machines, then the lower the memory requirements the better. i could agree with your statement for the i386 architecture... -given the fact that the warning of the "low memory mode" advices the administrator to allocate swap space as soon as possible, then doing it so at the very first opportunity should be possible.

well, anyway thanks for your answer... but what can i do? don't you think it could be optimized at least to be able to mount swap space?

Reply to: