[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

miboot floppies from layer-acht


as some of you may not remember, I posted a few times last year trying to get the miboot floppies available at people.debian.org/~wouterd-i/powerpc-miboot/.. to work. For those of you who don't know, the floppies are used for installing debian on 'old world' powerpc. The floppies are extremely important for using 'old world' macintosh, because otherwise you can't install debian unless you happen to have a OS8/9 installation medium, which is pretty hard to come by unless you're willing to buy it directly from apple (or wait 3 weeks for a torrent to come through like I did). Although most of these machines are going on 10 years old, alot of them preform pretty decently and can be used for firewalls, servers, surfing the internet, writing letters to mom, etc. By the way, mine is a power macintosh 6500/275.

The miboot floppies at ~wouter are made up of 3 floppies, of which at least one has always been broken (you could try and install with a fourth floppy, cd-drivers.img, but since I'm so cheap as to use a ten year old computer, then it should be of no big surprised that I'm to cheap to burn the CD necessary for this process). The etch beta3 d-i worked except that the net-drivers.img floppy necessary for network install was too big. Someone was so nice as to fix that, unfortunately only on a newer version of the boot floppy set, where the boot.img floppy was broken. I posted a bug report, but haven't heard about anything since. I tried the boot.img from today and that once again boots. Unfortunately now the root.img, necessary for installation doesn't work.

I get the following message:

No filesystem could mount root, tried cramfs
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

Also strange is when I put the image on floppy it's 1.3 MB but when I check it,after it's 1.5M:

rob@dude:~$ dd if=root.img of=/dev/fd0 bs=1024; sync
1307+1 records in
1307+1 records out
1339223 bytes (1.3 MB) copied, 105.846 seconds, 12.7 kB/s
rob@dude:~$ dd if=/dev/fd0 of=my_floppy.img bs=1024
1440+0 records in
1440+0 records out
1474560 bytes (1.5 MB) copied, 46.534 seconds, 31.7 kB/s

Now on to the actual subject of this mail. Holger Levsen was so nice as to hear the anguished cries of pain of old world mac debian users everywhere and has posted the legendary long disappeared sven luther miboot floppies, which have been known to work, to tide us over until the above mess is resolve. I also tried out these boot floppies made for sarge with kernel 2.4, and they worked! Well almost. A few notes though.

1.At one point you're asked if you want to install stable, unstable or testing. Won't this be a problem when sarge becomes old stable. I image the installation will fail here because it will start installing etch, which doesn't work with the 2.4 kernel.

2. There's no warning that you have to use a ext2 file system if you want to use quik. I know this is a known problem, but I'll say it again in case someone out there cares since it's a bitch to have to reinstall the base system on a 275 mhz machine with 96 mb ram.

3. Quik doesn't work. I know this "just happens" on some old world macs, but I hope that's not my case. I got the following error message:

This machine is not supported: AAPL,e411MacFisc (no big surprise there)
quik-installer failed with error code 1

I then went over to the terminal and tried running quik both on a chrooted filesystem and by changing into the /target directory and using the quik -r /target, both came out with error messages. The first one had something to do with /proc/cpu not being readable, the second one with /dev/hda2 not being mountable.

Unfortunately I didn't take any notes on those error messages or exactly what I did. Getting back into the installed system now that I turned off the computer is beyond me. Using the miboot floppies let's me boot and open a terminal, but I don't see /target or anything else I could mount.

I would appreciate any tips on how to get quik working with layer-acht floppies, just to prove it's possible. I'm also always up for testing the ~wouter floppies if there are any changes made there.

Rob Homsi

The MSN Entertainment Guide to Golden Globes is here. Get all the scoop. http://tv.msn.com/tv/globes2007/?icid=nctagline2

Reply to: