[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#405484: Debian Etch on ATARAID: progress

Package: installation-reports
Version: Etch installer daily build 01/01/07

Greetings. I'm continuing where I left off with bugs #286939, #291928 and
#292221. They were all concerned with installing on an ATARAID system using
the 2.4 ataraid/medley driver pair. If that method is now considered
obsolete (now that d-i defaults to 2.6 kernels using libata), those bugs
could be closed, even though they're not actually solved. I'm not sure of
your policy on such things. 

Anyway, I was messing around with Ubuntu recently when I discovered the
udpkg command. I realised that this could be the key to reinstalling Debian
on my machine. And it was. 

Instructions for installing Etch onto ATARAID arrays
Before you start partman (or after it has offered you only sda and sdb which
you don't want), start the shell on the F2 console and do the following four

1. modprobe dm-mod

2. udpkg -i /cdrom/pool/main/d/devmapper/dmsetup-udeb...... (whatever it's
called) (this step may not be necessary, I don't know if dmraid requires it
or not)

3. udpkg -i /cdrom/pool/main/d/dmraid/dmraid-udeb......

4. dmraid -ay

This should find your arrays and create the relevant devices for you in
/dev/mapper. I'm using a Silicon Image controller (SiI3112A), and it worked
for me. If it doesn't, you're no worse off than before I wrote this. If it
does, go back to the main menu and continue with partman. You can do your
partitioning, install the base system, choose a mirror, install more
software, all that stuff. The only slightly freaky thing is that it assumes
that your /dev/mapper devices are LVM2 volume groups, even when they're not.
This may or many not be relevant to what's below:

Outstanding problems with installing Etch onto ATARAID
There are two main problems remaining: 

1. You can't install a boot loader. The log console on F4 says at various
points "root is an LVM volume - can't install GRUB", and your only other
option is installing LILO. This fails with no explanation AFAICT, even
though it worked under 2.4 (see my previous bug reports noted above).
Actually the root is not an LVM volume, but d-i mistakenly thinks that all
your ATARAID devices are LVM volumes. Ubuntu installed GRUB perfectly well
on the same system, which is how I managed to unearth the other problem: 

2. Since I had GRUB already installed, I dropped into it and manually gave
it the following info, carefully copied down before rebooting:

root (hd0,3)
kernel /boot/vmlinuz-2.6.18-3-486 root=/dev/mapper/sil_aebdgidebbaj4
initrd /boot/initrd.img-2.6.18-3-486

It booted fine, but stopped at this point:

Begin: Mounting root file system ...
Begin: Running /scripts/local-top ...
Begin: Waiting for root file system ... ...

And it just stopped. I strongly suspect (though I run out of knowledge at
this point) that the kernel/initrd combo is not properly equipped with the
dm-mod module and the dmraid userspace tool, such that it can't find the
specified root fs. This is supported by screensful of "trying to read beyond
the end of device" error messages, where it's looking for sector 600000000
on /dev/sdb and hitting the end of the device at 300000000 (my medley array
is 2 x 160Gb disks striped, ie. 640000000 sectors or thereabouts). And also
some references to /dev/sd4, which is a dead giveaway that it's mistaken
that for /dev/mapper/sil_......4

Well, that's all for now. If you're interested I kept logs of both my
installation attempts (expert and normal) - you can get them at

My next attempt is to do a line-by-line comparison of the mkinitrd script
(for which I submitted a successful patch for 2.4) with the Ubuntu one,
which works fine (ie. supports dmraid properly). I may then be able to
finish the install, and supply a patch for others to use. Don't hold your
breath though - it takes me about a year between each set of attempts to
psych myself up for another go (I've been working on this since 2003).


No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.432 / Virus Database: 268.16.4/615 - Release Date: 03/01/2007

Reply to: