[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#392897: ntfsresize error is ignored, confusing the user

Package: debian-installer
Version: Etch Beta 3
Severity: important

Installing Debian Etch on my HP Pavilion DV6119US laptop, I naturally had to
resize the NTFS partition to make room.  Using the non-graphical installer,
I chose to manually edit the partition table, to resize the main NTFS
partition, and to make it 25 GB.  There was a pause, and then the installer
returned to the previous screen without changing anything.  No matter what
resizing I tried, the installer would seem to do nothing.

Getting a hint from the debian-user mailing list, I booted Knoppix and
manually ran "ntfsresize -i" against /dev/sda1.  It responded:

ntfsresize v1.13.1-WIP (libntfs 9:0:0)
Device name        : /dev/sda1
NTFS volume version: 3.1
Cluster size       : 4096 bytes
Current volume size: 66534257152 bytes (66535 MB)
Current device size: 66534257664 bytes (66535 MB)
Checking filesystem consistency ...
100.00 percent completed
Accounting clusters ...
Cluster accounting failed at 3147732 (0x3007d4): extra cluster in $Bitmap
Filesystem check failed! Totally 1 cluster accounting mismatches.
ERROR: NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
and will be made to NTFS by this software until it gets repaired.

Following ntfsresize's advice about chkdsk worked.  After doing that, the
installer was able to resize the partition flawlessly.

I suspect you don't have a routine to trap that particular error message, so
it just gets ignored.  It should instead be passed along to the user,
because it's important.

One side note: I had to run ntfsresize from Knoppix because if I switched to
VT2 (alt-F2) in the installer and ran any command that accessed the
filesystem (e.g. df, less, ntfsresize) the installer would freeze
unrecoverably 1-3 seconds later.

Thank you for all your work on Debian.  Let me know if I can help you
resolve this problem.

Reply to: