[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#378315: installation reports Asus P4P800 motherboard with Intel ICH5 disk controller

Package: installation-reports

Boot method: Disk 1 of the Debian CD set downloaded with jigdo
Image version: jigdo and template files dated 7-10-2006 files from ftp://mirrors.kernel.org/debian
Date: 7-14-2006 midnight

Machine: PC clone
Processor: Intel Pentium 4 3.2 GHz 800 MHZ bus
Memory: 1024 Mb PC3200 DDR

000001a0  bb 01 00 b4 0e cd 10 ac  3c 00 75 f4 c3 00 00 00  |........<.u.....|
000001b0  00 00 00 00 00 00 00 00  7d 10 7e 10 00 00 80 01  |........}.~.....|
000001c0  01 00 83 fe ff ff 3f 00  00 00 e1 1e bf 01 00 fe  |......?.........|
000001d0  ff ff 05 fe ff ff 20 1f  bf 01 9d 1d 39 0c 00 00  |...... .....9...|
000001e0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
000001f0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 55 aa  |..............U.|

Output of lspci:

00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801EB (ICH5) SATA Controller (rev 02)00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV35 [GeForce FX 5900XT] (rev a1)
02:0b.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
02:0c.0 Ethernet controller: 3Com Corporation 3c980-TX Fast Etherlink XL Server Adapter [Cyclone]

and lspci -n:

00:00.0 0600: 8086:2570 (rev 02)
00:01.0 0604: 8086:2571 (rev 02)
00:1d.0 0c03: 8086:24d2 (rev 02)
00:1d.1 0c03: 8086:24d4 (rev 02)
00:1d.7 0c03: 8086:24dd (rev 02)
00:1e.0 0604: 8086:244e (rev c2)
00:1f.0 0601: 8086:24d0 (rev 02)
00:1f.2 0101: 8086:24d1 (rev 02)
00:1f.3 0c05: 8086:24d3 (rev 02)
01:00.0 0300: 10de:0332 (rev a1)
02:0b.0 0780: 14f1:2f00 (rev 01)
02:0c.0 0200: 10b7:9800

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


This is Asus P4P800 motherboard in native mode SATA, with two IDE optical drives on IDE 0 and one Seagate Barracuda 
120 Gb SATA drive on SATA 1, which actually is ranked first rather than SATA 0.  I found the installer would not work on this system using the 2.6 kernel.  
The mode of the SATA  controller made a difference.  In native controller mode the Install CD could not be mounted on the first attempt,
but always could be mounted on the second try.  In compatibility mode the CDrom drive could not be found.  The installation steps after detect and mount 
CDrom were very slow with the 2.6 kernel.  Eventually installation would fail because the disk partitioner would stall after making the root filesystem.  
I left the machine overnight a few times to see if the install would continue, but it did not.  After the creation of the root partition, with root
filesystem progress bar reading 100%, the install would not progress.  I tried the optical drives on IDE 1, but this made no difference.

Finally I remembered, when installing Etch on a similar system, but using an Intel 865PERL motherboard, I had to use the 2.4 kernel for installation.
I tried "expert24" for an installation option and everything went well.  I was not able to install any 2.6 kernel packages because of errors with 
dpkg (9), so I left the 2.4-SMP kernel to be installed.  The system had problems with yaird and initramfs-tools making an initrd image
for a 2.6 kernel using the 2.4 kernel install.  

The system was configured as desktop, standard installation, with no custom software selection, only tasksel options.  On reboot the xserver was unable
to load.  This may have been due to the mouse not being detected.  I installed yaird, the 2.6.15-8 SMP kernel, and some dependencies using dselect.  
But, /etc/fstab needs to be manually edited, changing "hdx" to "sda" for 2.4 to 2.6 kernel changes.  Once that was done the system booted into 
the xserver.  Since 'dpkg-reconfigure xserver-xorg' will not configure the monitor, I had to manually edit /etc/X11/xorg.conf so the monitor 
sync rates were correct.

The system will not run in native mode SATA with the Intel ICH5 controller, even with the 2.6 kernel.  This is interesting because other 
motherboards with the same controller will run in native mode SATA with Debian Etch.

This is unacceptably poor performance of the Debian installer.  I could find no reference to this exact problem, so I filed this report.

Thomas Kayser

Reply to: