[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#374278: Install report: 12Ã" PowerBook G4 1.33Ghz



Hoi Wouter,

On Sunday 18 June 2006 12:48, Wouter Verhelst wrote:
> I couldn't find the install-report template on my hard disk (maybe I'm
> not looking at the right place; it used to be in /root, but it's not
> there now), so I'm doing things manually.

Correct. It has been replaced by a template in reportbug

> The installation went fine up to the point where I tried to use LVM
> rather than a "regular" install partition; I could create a physical
> volume in the partman interface, but when I tried to create a volume
> group with that one, the LVM interface would quit, and I would be
> dumped back in the "regular" partman interface. After I'd changed the
> partition type from being an LVM PV to an XFS filesystem, the
> installation went on.

I'm going to ignore this until we get to debug it a bit more as agreed...

> The reboot didn't work, however. The first message I got was one of
>
> RAMDISK: Compressed image found at block 0
> RAMDISK: incomplete write (-28 != 32768) 8388608
>
> at which point it failed to go on. I tried booting with a different
> kernel (the one of my already-installed unstable system), but the
> initrd of that one apparently ignores root= kernel command line
> parameters, so it didn't help much. I also tried booting with the
> parameter 'ramdisk_size=20000' (if I tried 10000, it failed a bit
> further on), but then the system would complain that it could not find
> root on "unknown-device(0,0)".

I can't help very much as I'm totally unfamiliar with bootloading on ppc, 
but some general suggestions may help narrow things down.
Try using the rescue option of d-i to get a chroot on the installed 
system:
- check what the uncompressed size of the generated initrd is
- try booting with break={top,modules,premount,mount,bottom,init}; this
  will give you debug shells at different points in the initramfs stage;
  check the value of env var ROOT.
- make a copy of it for future reference and debugging
- try installing yaird, build an initrd with that and see if that boots

As ramdisk_size does seem to make a difference, I guess that is part of 
the problem. Did you get dropped into a debug shell after the 
"unknown-device(0,0)" error?
Maybe maks (as initramfs-tools maintainer) can offer some help as well.

Attachment: pgpEHNIOqMUc6.pgp
Description: PGP signature


Reply to: