[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: libdebian-installer Packages support proposal

On Tue, May 16, 2006 at 10:52:19AM -0500, Joey Hess wrote:
> Bastian Blank wrote:
> > With this, the following changes can be done easily.
> > 
> > * Support for udebs per frontend.
> Not sure what this means exactly..

For cdebconf plugins, we need to be able to do something along the lines
of this:

  Package: cdebconf-newt-entropy
  Provides: cdebconf-entropy
  XB-Debconf-Frontend: newt

  Package: partman-crypto
  Depends: cdebconf-entropy

... and have anna only allow this to be loaded if you're running the
newt frontend. At present, partman-crypto Depends:
cdebconf-newt-entropy, which obviously isn't ideal for the graphical

This is analogous to the existing Kernel-Version: field.


Colin Watson                                       [cjwatson@debian.org]

Reply to: