[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Report on PowerPC Installation Experiences

Hash: SHA1

Hello D-I Team,

I have finally had a successful couple of installs on an 'old world'
mac-clone and would like to report to you on my experiences.  Some of
the findings are things for which I will submit patches to the
installation manual, and others will have to wait until I get into the
d-i code (and scripts, and packages lists, etc).

First my hardware environment:

It's a StarMax 4000/160 with 96 Mib of RAM, which uses an Apple
Tanzania motherboard, and which MacOS 9.1 System Profiler reports as a
PowerMac 4400.  I initially installed onto a 9.1 GB SCSI hard drive,
and when I was having trouble with that, a 6.4 GB IDE drive, and once I
achieved success retried the scsi drive.

At this point I haven't successfully installed a dual boot environment,
but I anticipate that I will be able to do so later this week.  

The first challenge was booting the installer.  Last week I tried the
miBoot-enabled boot floppies, but all that happened is that they got
ejected.  The version of miBoot that comes with BootX got further
(kernel messages appeared, but the screen was unreadable), but because
I couldn't read the messages I didn't pursue it beyond noting that it

Using BootX on a MacOS partition, on the other hand worked fine.  It
only works with the vmlinux kernels, not any of the vmlinuz-xxx kernels,
even the vmlinuz-coff kernel.  Once I had BootX, vmlinux, and an the
installer initrd.gz in the same folder (HFS+ works fine, probably
because the kernel and ramdisk are in memory not read from disk).  I
have had success with the mini.iso for netboot as well as a renamed
netinst.iso (the default name of debian-powerpc-testing-....iso is too
long for HFS, but once it's renamed to netinst.iso all is fine) with
the cd install kernel and initrd.gz. The iso must be on an HFS
partition (possibly a FAT partition will do as well, but I haven't
tried that yet), not HFS+.

Once I got BootX working, I went through the install process.  For IDE
the process went smoothy, with the exception that, because quik
requires that the kernel and initrd be on ext2 but partman defaults to
ext3, once you get to the quik install portion of the install you get
an error message, and kicked into the menu.  On each menu step, the
quik installation is automatically retried, which means that after
re-partitioning, before you get a chance to install the base system,
the installer tries to redo the quik install step, which fails with an
error message.  It's a bit annoying, but goes away once you reinstall
the base system.

On reboot, quik does it's thing, but no kernel messages are displayed
on the screen (maybe they're getting sent to OpenFirmware's
output-device instead of the framebuffer device?), which, the first few
times I tried installing, made me think the machine was hung.  Wait
long enough, however, and you get the login: prompt.

SCSI is not so happy, unfortunately.  It just sits at the penguin logo
screen (top left corner of the screen) and does nothing.  I suspect that
this is because the necessary driver is not being included in the
ramdisk by initramfs-tools (I had a similar problem with
initramfs-tools on i386), so I will be trying yaird to see if it makes
a difference.

Also, for scsi, the quik-install step fails during OpenFirmware update
step.  Going to vc/2, chroot'ing into /target, and using 
'nvsetenv boot-device "scsi-int@sd0@0"' 
followed by a manual quik install (I'll have to check the exact command
line I used, basically I manually set the first.b, second.b, and config
file) seems to work (although it's possible that failure to boot is
because the manual quik install is wrong) seems works.  At least the
nvram is set as it should be and quik executes on boot (so the mbr is
correct at least).

I'll report more on the my scsi tests, as I perform them.  I also
intend to try dual boot with quik and BootX.

I have also figured out that a netinst cd with bootx could be used to
bootstrap the system, if you have a MacOS 8.1 DiskTools 2 PPC floppy
(downloadable free of charge from apple.com) with an Apple CD-ROM
driver instead of Disk FirstAid.  It requires a non-free floppy, but I
believe the cd would still be dfsg-free (at least BootX was included
with woody, but I will have to double-check the license).

Ideally the miBoot floppies will work (and I will be trying the latest
versions once I finish with my scsi tests).

Also, I will copy the logs to floppy before rebooting, so that I can
submit them as well.



- -- 
And that's my crabbing done for the day.  Got it out of the way early, 
now I have the rest of the afternoon to sniff fragrant tea-roses or 
strangle cute bunnies or something.   -- Michael Devore

Version: GnuPG v1.4.1 (GNU/Linux)


Reply to: