[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#333058: Debian sarge install, grub fatal error with sata drive...

Package: Debian Sarge

Procedure: Install on system with sata drive.

Issue: install has fatal error upon grub install.

Searches on the web have brought various related incidents, however there is no true resolution for this issue. I have done the following:

Installed Debian in expert mode at least ten times with the same exact failure each time with attempting different approaches.

I have entered the partition in each of the grub format (hd2,1) /dev/sda etc... Each time the install of grub gets to 50% and then brings up a fatal error window.

Alt f4 and Alt f3 each show little tidbits of info, yet none of it has helped to resolve this issue.

Alt f3 says that grub/stage1 can not be read

Alt f4 says that grub-install (with each of the attempted partition notation formats from above) failed

I have additional ide drives on the system in primary master and secondary master positions. I have shutdown the system and unplugged the ide cables to make this system only have the sata and still had this issue.

I have tried finishing without configuring grub and couldn't get back in with the grub parameters that were recommended. kernel (hd2,0) /vmlinuz root=/dev/sda4

I have tried (hd2,1), /dev/sda /dev/sda1 (hd0,1) and eve let the system place grub in the mbr which also failed! I have also tried using partition types of ext2 ext3 and even jfs for the /boot partition. None of these changes have helped

I have attempted to force this to go and have had no resolve.

I have read of others removing the ide drives from the picture. I have also read of one guy who reinstalled with being careful of his syntax and found that if he entered the syntax correctly the first time it would fly, yet one typo and changes could not be made after that without an entire fresh install attempt.

This is most certainly a bug as most every other install I have ever done has placed Grub most simply.

I have installed Sarge on one other system with a sata drive, so this is not just about sata drives. Both of these systems are running on Elite Group Motherboards, although different models. I assume that this could be related to translation of the bios?

Please help?

Thanks in advance and sorry for this being an issue that has been reported before. The difference is that there is not a solid result to be tried in dealing with this issue. I will try any test or answer any questions to aid in fixing this issue.


Reply to: