[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]


Package: installation-reports


Debian-installer-version: debian-31r0a-i386-netinst.iso via http from(I forget)
uname -a: Linux blackpearl 2.4.27-2-386 #1 Mon May 16 16:47:51 JST 2005 i686 GNU/Linux
Date: July 22-23, 2005
Method: How did you install?  LILO (from a woody system) and the netinst.iso
  What did you boot off? several attempts; see below

BIOS is Award V1.0A, 1998 (If I remember Correctly)
Machine: Pentium III 450 MHz  AOpen Custom PC
Processor: Pentium III
Memory: 288MB
Root Device: IDE /dev/hdd 
Root Size/partition table:

  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.

has WinNT, potato.  Not used at present except for the MBR

                                  cfdisk 2.12p

                              Disk Drive: /dev/hda
                        Size: 20416757760 bytes, 20.4 GB
              Heads: 255   Sectors per Track: 63   Cylinders: 2482

    Name        Flags      Part Type  FS Type          [Label]        Size (MB)
    hda1                    Primary   Linux ext2                         419.49 
    hda2        Boot        Primary   FAT16          [NO NAME    ]       945.91
    hda3                    Primary   Linux ext2                         633.35
    hda5                    Logical   FAT16          [WINDATA    ]       427.72
    hda6                    Logical   FAT16          [WINDATA2   ]       732.05
    hda7                    Logical   Linux swap / Solaris               139.83
    hda8                    Logical   Linux ext2                        1571.03
    hda9                    Logical   Linux                              526.42
    hda10                   Logical   Linux ext2                        2615.64
    hda11                   Logical   Linux ext2                        1998.75
    hda12                   Logical   Linux ext2                        1998.75
    hda13                   Logical   Linux ext2                        1998.75
    hda14                   Logical   Linux ext2                        6407.50

   has two systems: woody and sarge.  Perhaps most easily described 
   by the current fstab:

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hdd3       /               ext2    defaults,errors=remount-ro 0       1
/dev/hdd10      /usr            ext2    defaults        0       2
/dev/hdd8      	/usr/local      ext2    defaults        0       2
/dev/hdd5       none            swap    sw              0       0
/dev/hdb        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hdc        /media/cdrom1   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

# The woody system
/dev/hdd1	/mnt/woody		ext2	ro	0	3
/dev/hdd2	/mnt/woody/tmp		ext2	ro	0	3
/dev/hdd6	/mnt/woody/usr		ext2	ro	0	3
/dev/hdd7	/mnt/woody/var		ext2	ro	0	3
# empty partitions
/dev/hdd9	/mnt/empty1	ext2	defaults	0	3

                                  cfdisk 2.12p

                              Disk Drive: /dev/hdd
                        Size: 17280442368 bytes, 17.2 GB
              Heads: 16   Sectors per Track: 63   Cylinders: 33483

    Name        Flags      Part Type  FS Type          [Label]        Size (MB)
    hdd1                    Primary   Linux ext2                         100.13
    hdd2                    Primary   Linux ext2                         100.13
    hdd3        Boot        Primary   Linux ext2                         100.13
    hdd5                    Logical   Linux swap / Solaris               500.10
    hdd6                    Logical   Linux ext2                        3000.07
    hdd7                    Logical   Linux ext2                        3000.07
    hdd8                    Logical   Linux ext2                        3000.07
    hdd9                    Logical   Linux ext2                        1999.88
    hdd10                   Logical   Linux ext2                        5479.91

(I don't know why the swap is labeled "Solaris".  It is the swap partition for
the woody and sarge systems.)

Output of lspci and lspci -n:

blackpearl:/# (lspci; lspci -n) | sort
0000:00:00.0 0600: 8086:7190 (rev 03)
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 0604: 8086:7191 (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 0601: 8086:7110 (rev 02)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 02)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:09.0 0401: 1274:1371 (rev 06)
0000:00:09.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)
0000:00:0b.0 0200: 10b7:9200 (rev 74)
0000:00:0b.0 Ethernet controller: 3Com Corporation 3c905C-TX/TX-M [Tornado] (rev 74)
0000:01:00.0 0300: 1002:4742 (rev 5c)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [E]
Final boot worked:      [OK]
Configure network HW:   [OK]
Config network:         [OK]
Detect CD:              [OK]
Load installer modules: [OK]
Detect hard drives:     [OK]
Partition hard drives:  [ ]  I did this before the install
Create file systems:    [ ]  I did this before the install
Mount partitions:       [ ]  I did this before the install
Install base system:    [OK]
Install boot loader:    [OK]
Reboot:                 [OK]


Why install a new sarge instead of upgrade the existing woody?
I have been using the woody system on /deb/hdd for some time.  It is
the result of a mass copy from /deb/hda (Not a good idea, but /dev/hda
was giving out nasty error messages, and I felt I had to get off it
quickly), and not everything was quite right.  So I chose to install a
new sarge, rather than upgrade the woody system.

Install attempt # 1: (failed)
  Tried using debootstrap (in the woody system) and the netinst CD.
    This failed quickly with something like 
       "cannot download console-toolkits-<I forget>"
    I tried again, excluding that package, and it failed again on exim.
    It looks to me as though debbotstrap was using an incorrect list of 
    (repeat several times)
  I then downloaded debootstrap for sarge, and installed it on the woody 
  system. debootstrap failed on a library dependency (libc6 I believe).

Install attempt # 2: (failed)
  Tried booting from netinst CD:
    console message: 
      "ISOLINUX 2.04 2003-04-16 isolinux; Disk error01, Ax=4224,9F"

Install attempt # 3: (failed)
  Tried booting from Bin-1 CD:
    console message: 
      "ISOLINUX 2.04 2003-04-16 isolinux; Disk error01, Ax=4266,9F"

Install attempt # 4: (failed)
  Tried booting from Bin-2 CD:
    console message: 
      Boot from STATPI CD-ROM:
      1. FD 2.88 MB System Type -(00)
      Boot failed

Install attempt # 5: (failed)
  Tried booting from Bin-3 CD:
    console message: 
      CD not bootable.
  (Same results using Bin-3 and Bin-4.)

Install attempt # 6: (failed)
Then I found a note in one of the list archives that included this
note from "roach" - for which I thank him.
==================================== start ===================
Another one to add, some BIOS's don't like isolinux. If this is the case 
you'll need a installation boot floppy or Smart Boot Manager.

Robert "roach" Spencer
South Africa
==================================== end ===================
So I went to the manual again, and used the "Boot from Linux using 
LILO or GRUB" procedure.  It worked like so:
  choose language, country, keymap.
  ask for CD-ROM
  scan CD, load debian-installer
  detect NIC
  -- hang --
  (repeat several times)

Install attempt # 7: (Sucess!)

Once more I read the manual, which mentions trouble detecting fax
modems.  So I removed the fax-modem (US ROBOTICS Model 0726), and the
second NIC card, and restarted as above.  The install went as slick as
anyone could want.  I choose the "desktop" type install.  Sound works,
and Gnome is quite nice - In woody I used icewm only.

Hope this helps.  Will be glad to forward any other info.

Douglas Guptill      voice: 902-461-9749
18 Lynn Dr.          email: dguptill@accesswave.ca
Dartmouth, N.S.      web: www.accesswave.ca/~guptilld
B2Y 3V9, Canada  

Reply to: