[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#307104: INSTALL REPORT: Dell Latitude D810, d-i RC3

Package: installation-reports
X-Debbugs-CC: qjb@debian.org


Debian-installer-version: Debian-installer RC3 (3/22/2005) with
  comments from testing snapshot of 2005-04-30 from

uname -a: Linux quadrilateral 2.6.10-1-686 #1 Fri Mar 11 03:55:46 EST 2005 i686 GNU/Linux
Date: April 30, ~14:00 UTC
Method: How did you install?  What did you boot off?  If network
      install, from where?  Proxied?

  Booted/installed from netinst CD; then upgraded to sid using my
  local mirror.

Machine: Dell Latitude D810
Processor: P4M 2.0 GHz
Memory: 1 GB
Root Device: S-ATA, /dev/hda with 2.4 kernel, /dev/sda with 2.6 kernel
Root Size/partition table:  Feel free to paste the full partition
      table, with notes on which partitions are mounted where.

Disk /dev/sda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1           7       56196   de  Dell Utility
/dev/sda2   *           8          13       48195   83  Linux
/dev/sda3              14         815     6442065    7  HPFS/NTFS
/dev/sda4             816        7296    52058632+   5  Extended
/dev/sda5             816        1544     5855661   83  Linux
/dev/sda6            1545        3845    18482751   83  Linux
/dev/sda7            3846        6143    18458653+  83  Linux
/dev/sda8            6144        7047     7261348+   b  W95 FAT32
/dev/sda9            7048        7296     2000061   82  Linux swap / Solaris

/dev/sda2 -> /boot
/dev/sda5 -> /

/dev/sda3 is not mounted but has a restored ghost image of XP as
originally installed.  Other partitions have data and are not yet

Output of lspci and lspci -n:


0000:00:00.0 Host bridge: Intel Corp. Mobile Memory Controller Hub (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. Mobile Memory Controller Hub PCI Express Port (rev 03)
0000:00:1c.0 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
0000:00:1d.3 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev d3)
0000:00:1e.2 Multimedia audio controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Audio Controller (rev 03)
0000:00:1e.3 Modem: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) AC'97 Modem Controller (rev 03)
0000:00:1f.0 ISA bridge: Intel Corp. 82801FBM (ICH6M) LPC Interface Bridge (rev 03)
0000:00:1f.2 IDE interface: Intel Corp. 82801FBM (ICH6M) SATA Controller (rev 03)
0000:00:1f.3 SMBus: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 5460
0000:02:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
0000:03:01.0 CardBus bridge: Texas Instruments: Unknown device 8036
0000:03:01.5 Communication controller: Texas Instruments: Unknown device 8038
0000:03:03.0 Network controller: Intel Corp.: Unknown device 4223 (rev 05)

lspci -n:

0000:00:00.0 0600: 8086:2590 (rev 03)
0000:00:01.0 0604: 8086:2591 (rev 03)
0000:00:1c.0 0604: 8086:2660 (rev 03)
0000:00:1d.0 0c03: 8086:2658 (rev 03)
0000:00:1d.1 0c03: 8086:2659 (rev 03)
0000:00:1d.2 0c03: 8086:265a (rev 03)
0000:00:1d.3 0c03: 8086:265b (rev 03)
0000:00:1d.7 0c03: 8086:265c (rev 03)
0000:00:1e.0 0604: 8086:2448 (rev d3)
0000:00:1e.2 0401: 8086:266e (rev 03)
0000:00:1e.3 0703: 8086:266d (rev 03)
0000:00:1f.0 0601: 8086:2641 (rev 03)
0000:00:1f.2 0101: 8086:2653 (rev 03)
0000:00:1f.3 0c05: 8086:266a (rev 03)
0000:01:00.0 0300: 1002:5460
0000:02:00.0 0200: 14e4:1677 (rev 01)
0000:03:01.0 0607: 104c:8036
0000:03:01.5 0780: 104c:8038
0000:03:03.0 0280: 8086:4223 (rev 05)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O] -- with vga=771
Configure network HW:   [O] -- did not see wireless
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O] -- but see below
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


The D810 is very new hardware, so there were, not surprisingly, a few
problems.  This is my first experience with S-ATA, so this may be
normal, but the 2.6 kernel treats the primary drive as a SCSI drive.
(It took me a while to figure this out.)  Booting debian-installer
with linux26 resulted in failure detecting the hard drives both with
RC3 and the 20050430 snapshot.  Debian-installer reports: "No
partitionable media were found."

I had to use the default 2.4-based install and upgrade the kernel
later.  Interestingly, Ubuntu Hoary (5.04) detected the drive and
installed fine, though I no longer have it loaded on the disk.

This system required vga=771 in order for the screen to work.  The
console performance is horrid with the 2.4 kernel but is just fine
with the 2.6 kernel.  (This was true with 2.4 and 2.6 and with Ubuntu
as well.)

What I did to get a basically working system was to install using
linux vga=771 and, after the first reboot, wade through the slow
console long enough to install kernel-image-2.6.10-1-686, change the
root device from /dev/hda5 to /dev/sda5 in /boot/grub/menu.lst, change
all occurrences of hda to sda in /etc/fstab, and reboot.  I have still
not figured out how to access the CDROM drive with the 2.6 kernel,
though Ubuntu can see both the hard drive and CD drive (both as SCSI
devices), so I know it's possible.  There were other problems, but
they don't have anything to do with debian-installer, so I won't
mention them.

Gratuitous remark: Ubuntu's live CD and installation process are
obviously based on debian-installer.  They worked without any problems
at all -- all hardware on this laptop that I've tested so far has
worked correctly, and the install ran without a hitch.  Even the
built-in wireless was detected during installation.  Interesting.

Jay Berkenbilt <qjb@debian.org>

Reply to: