[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problems booting into Debian installer on PowerMac G5



On Sun, Apr 03, 2005 at 04:21:38AM +0100, Noah Slater wrote:
> Hello,
> 
> Eventually I got to the partitioning screen. After opting to erase the
> whole disk and then being asked what type of setup I would like the
> installer presented me with the following information of it's intended
> partitioning:
> 
> #1  32.8 KB                      Apple
> #2  1.0 MB      boot   untitled
> #3  244.8 GB    ext3   untitled  /
> #4  6.2GB       ext3   swap      swap

This looks OK.

> 
> ---------------------------
> First Stage GNU/Linux Bootstrap
> 
> Press l for GNU/Linux,
>       c for CDROM
> 
> Stage 1 boot: l
> 
> Loading second stage bootstrap...
> ---------------------------
> 
> At this point, the same flashing question mark/folder icon came up.
> Nothing happened for a minute or so and then the screen reset it's
> self - presenting me with the same initial option.

This means that the first stage yaboot (the ofboot.b OpenFirmare script) is unable
to load the second stage. The root cause of this is probably that the
ofpath utility does not correctly identify the OpenFirmware path to your
Bootstrap partition (where the yaboot second stage is installed).

I think we already solved a similiar problem once on the debian-powerpc
list. You can find my description on how to find the correct OF path in
http://lists.debian.org/debian-powerpc/2005/02/msg00049.html

Probably it is the best approach to first try to get the into OF and to
try to boot the second stage yaboot directly from there. Like this you
can find out the correct OF path and then later fix your yaboot.conf. I
guess that the real bug lies in the ofpath utility. If you can confirm
this please report a bug on the yaboot package or add your information
to #294081 if you think that it is the same issue.

Gaudenz

-- 
Ever tried. Ever failed. No matter.
Try again. Fail again. Fail better.
~ Samuel Beckett ~

Attachment: pgpCgk9oQ7jzi.pgp
Description: PGP signature


Reply to: