[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#301381: Debian Installation Report: failure of debian-installer RC3 on a Dell Latitude D610 (SATA related)

Package: installation-reports

Debian-installer-version: March 23, 2005 - RC3 version

uname -a: "Linux han-solo 2.6.8-2-386 #1 Mon Jan 24 03:01:58 EST 2005
i686 unknown"
Date: March 24, 2005
Method: RC3 netinstall bootable disk

Machine: Dell Latitude D610
Processor: Intel Pentium M 1.86 Ghz, 2Mo of cache (Centrino Sonoma)
Memory: 1Gb DDR2
Root Device: single SATA drive ( should be /dev/sda1 if the installer
had detected my drive :)
Root Size/partition table: <Feel free to paste the full partition
      table, with notes on which partitions are mounted where.>
Output of lspci and lspci -n:

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [ O ]
Configure network HW:   [ O ]
Config network:         [ E ]
Detect CD:              [ O ]
Load installer modules: [ O ]
Detect hard drives:     [ E ]
Partition hard drives:  [ ]
Create file systems:    [ ]
Mount partitions:       [ ]
Install base system:    [ ]
Install boot loader:    [ ]
Reboot:                 [ ]


* regarding "Config network" (minor issue).

I'm using static DHCP so before the install I entered the MAC address of
the ethernet adapter in our DHCP server so this client will always get
the same IP.

During the "Configure the network" stage the name of the laptop is
detected automaticly thanks to the DHCP and DNS entry, but during the
second step of that stage the "Domain name" field is empty (same issue
with the RC2 version).
This because I set up my DHCP server to return multiple domain names, so
I my /etc/resolv.conf I have something like:
vivien@han-solo:~$ cat /etc/resolv.conf
search my-personnal-domain.net my-company.com
It will still get an IP address from the DHCP server. (I checked in
console mode with ifconfig).
looking at the /etc/resolv.conf I see that the domain name is present
with the right value (even if I didn't enter anything in the "domain
name" field).

The "domain name" value displayed during the "Configure the network"
stage is field correctly if I changed the setup of my DHCP server to
only return a single domain

As the config is written correctly in both cases, it looks more like a
display issue.

* Regarding "Detect hard drives"

No partionable media were found.
This probably failed because the RC3 version of the installer is still
using a 2.6.8 kernel. This kernel support SATA hard drives but not in
AHCI mode (which is supported since 2.6.10 [1]).
I had the same issue installing a Dell Precision 370 using a SATA drive
but there was an option in the BIOS to disable AHCI, unfortunately
that's not the case there.
I just hope the final debian-installer version will use a more recent
kernel that is SATA AHCI aware.

Thanks for your hard work, Debian is making system administration easier
every day.


[1] http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.10
	[libata] add AHCI driver

Reply to: