[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

d-i problem on sparc32 with partitions

Hi, I tried to install sarge on Sun Sparcstation 5/170 with the latest installer, debian/dists/sid/main/installer-sparc/20050317/images/sparc32/netboot/2.6/boot.img and failed.

Everything went fine until I started partitioning the disk. It's a 4.3G COMPAQ ST34371W (Seagate). Previously it was partitioned like that (only sizes and names from /proc/partitions copied by hand from the screen):

4193000 sda
1855440 sda1
1855440 sda2
4190400 sda3

I don't know what disklabel it used, dmesg didn't tell anything about disklabel type.

I chose to erase entire disk, then /proc/partitions showed this suspicios table:

4193000 sda
2147483647 sda3

And then I chose to use single partition and got error message telling
Failed to partition the selected disk
This probably happened because there are too many (primary) partitions in the partition table.

I tried with 2.4.24-based netboot installer from the same directory, clearing the partition table with dd before. Still the same - it created 2T sda3 and then failed. So it seems to be not kernel-specific but rather parted.

Looks like it failed in creating the whole disk partition and/or quessing wrong the disk size.

Meelis Roos (mroos@linux.ee)

Reply to: