[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: tulip_cb support?

Joey Hess <joeyh@debian.org> wrote:
> Walter Landry wrote:
> > pcmcia-modules-2.4.27-2-386 has it.
> Ok. That's the modules from pcmcia-cs that I mentioned we've avoided
> including in the installer. However, I still don't see the tulip.o you
> speak of:
> Unpacking pcmcia-modules-2.4.27-2-386 (from
> .../pcmcia-modules-2.4.27-2-386_3.2.5+2_i386.deb) ...
> Setting up pcmcia-modules-2.4.27-2-386 (3.2.5+2) ...
> joey@dragon:~>dpkg -L pcmcia-modules-2.4.27-2-386| grep tulip
> /lib/modules/2.4.27-2-386/pcmcia/tulip_cb.o

I must have been unclear.  pcmcia-modules-2.4.27-2-386 has tulip_cb.o.
However, I can just use the tulip module from the kernel pcmcia, and
it works fine.

So the trick is to not let the system autodetect the network card by
not plugging it in, then plug the card in and manually select the driver.

> > Once I rebooted, I got a kernel panic if I kept the PCMCIA card
> > inserted.  If I leave it out, I manually unloaded tulip.o, inserted
> > the card, loaded tulip.o, and then ran dhclient.  Otherwise, it all
> > went fine.

For various reasons, I reinstalled the system.  It turns out I was
mistaken.  There is no problem leaving the PCMCIA card inserted.
However, it does kernel panic if I let it reboot.  If I shut the
computer off and restart, then there is no problem.

Also, I don't have to do anything with the tulip.o modules.  I only
have to run dhclient.  I think that is because the eth0 interface does
not show up until I run dhclient, so the installer does not think that
it can run dhclient.

> > So I now have a functioning system.  However, it looks like hardware
> > detection with PCMCIA cards could use some work.
> Take a look at /etc/pcmcia/config. cardctl ident should show the
> information for your card, then if you find the matching part of that
> file you can change it to use tulip instead of tulip_cb it.

Well, in the URL I quoted, it says that this card is no longer handled
by the PCMCIA subsystem, but the hot plug subsystem.  So there is no
entry in /etc/pcmcia/config.

Walter Landry

p.s. As a point of interest, I used the XFS filesystem for all
partitions, and it worked flawlessly.

Reply to: