[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Pre-RC3 installation reports on sparc

On Sun, 13 Mar 2005, Joey Hess wrote:

Jurij Smakov wrote:
CD netinst install  - ok
2.4 netboot install - ok
2.6 netboot install - fails on initial boot with the error:

VFS: Mounted root (ext2 filesystem).
Freeing unused kernel memory: 124k freed
EXT2-fs error (device ram0): ext2_check_page: bad entry in directory #2:
unaligned directory entry - offset=0, inode=1887317007, rec_len=53961,
Warning: unable to open an initial console.
Kernel panic: No init found.  Try passing init= option to kernel.

I am pretty sure that this is due to genext2fs generating broken d-i
initrd image. I'll investigate further.

Suck. This worked in rc2 didn't it?

I will have to check that, but joshk does not recall ever having working 2.6 images for sparc32. And I've checked that it is not really a genext2fs fault. A netboot image with cramfs initrd also fails, as if the image
is corrupt. Looks like there is some kernel problem, so that it fails
to properly copy initrd in place, or something.

I have also tried 2.4 and 2.6 netboot installs on another sparc64 machine I have (Ultra 5). 2.4 works fine, 2.6 hangs due to a bug in sunsab serial console driver, presumably it is the same problem you've seen on your machine. I have committed a fix for that to 2.6.8 branch of debian-kernel SVN, so it will most likely make it into the final release (not RC3 though).

Best regards,

Jurij Smakov                                        jurij@wooyd.org
Key: http://www.wooyd.org/pgpkey/                   KeyID: C99E03CC

Reply to: