[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#298595: [i386] [20041118] [netinst] USB2 drive boot - failed to boot, an IBM workstation

Package: installation-reports
Severity: normal

I apologize in advance for not having collected all the possibly
relevant info about the machine. I have only had limited access to it
today; I'll try to collect more info off it later. Also, I'm not
allowed to open it and I don't have access to things like the
motherboard docs, although I am allowed to reinstall it as I please.
Please tell me if the lspci info (below) gives enough clues, or
if still more info is needed.

I am trying to boot sarge-i386 (the current image) off an M-Systems USB
2.0 drive, w/2 partitions, the 1st of them being prepared "the easy way"
as per http://d-i.pascal.at/ -- took the boot.img.gz off
and did 
	zcat boot.img.gz > /dev/sdb1
and then copied the netinst image manually over into the 
partition initialized as above (after mounting it, of course).

When I try to boot, the system prints

	Attempting to boot from the USB drive
	Boot failed

Later on I tried doing 
	install-mbr /dev/sdb 
	syslinux /dev/sdb1  
which both silently worked,
and boot after each of these 2 steps, but it didn't help. This is
what the USB disk looks like (from within another computer):

# fdisk /dev/sdb

Command (m for help): p

Disk /dev/sdb: 255 MB, 255590400 bytes
8 heads, 61 sectors/track, 1022 cylinders
Units = cylinders of 488 * 512 = 249856 bytes

   Device Boot      Start         End      Blocks   Id  System
   /dev/sdb1   *           1         544      132705+   e  W95 FAT16 (LBA)
   /dev/sdb2             545        1022      116632   83  Linux

# mount /dev/sdb1 /mnt
# cd /mnt
# ls
disk.lbl  f3.txt  f7.txt       initrd.gz    sarge-i386-netinst.iso
f10.txt   f4.txt  f8.txt       ldlinux.sys  splash.rle
f1.txt    f5.txt  f9.txt       linux        syslinux.cfg
f2.txt    f6.txt  initrd26.gz  linux26      syslinux.txt

Booting the same computer off its presently installed old Mandrake image
allowed me to fetch the following info about the machine:
% lspci -n
00:00.0 Class 0600: 8086:2570 (rev 02)
00:01.0 Class 0604: 8086:2571 (rev 02)
00:1d.0 Class 0c03: 8086:24d2 (rev 02)
00:1d.1 Class 0c03: 8086:24d4 (rev 02)
00:1d.2 Class 0c03: 8086:24d7 (rev 02)
00:1d.7 Class 0c03: 8086:24dd (rev 02)
00:1e.0 Class 0604: 8086:244e (rev c2)
00:1f.0 Class 0601: 8086:24d0 (rev 02)
00:1f.1 Class 0101: 8086:24db (rev 02)
00:1f.2 Class 0101: 8086:24d1 (rev 02)
00:1f.5 Class 0401: 8086:24d5 (rev 02)
01:00.0 Class 0300: 10de:0181 (rev a2)
05:02.0 Class 0200: 14e4:1696 (rev 03)
% lspci
00:00.0 Host bridge: Intel Corp.: Unknown device 2570 (rev 02)
00:01.0 PCI bridge: Intel Corp.: Unknown device 2571 (rev 02)
00:1d.0 USB Controller: Intel Corp.: Unknown device 24d2 (rev 02)
00:1d.1 USB Controller: Intel Corp.: Unknown device 24d4 (rev 02)
00:1d.2 USB Controller: Intel Corp.: Unknown device 24d7 (rev 02)
00:1d.7 USB Controller: Intel Corp.: Unknown device 24dd (rev 02)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corp.: Unknown device 24d0 (rev 02)
00:1f.1 IDE interface: Intel Corp.: Unknown device 24db (rev 02)
00:1f.2 IDE interface: Intel Corp.: Unknown device 24d1 (rev 02)
00:1f.5 Multimedia audio controller: Intel Corp.: Unknown device 24d5 (rev 02)
01:00.0 VGA compatible controller: nVidia Corporation NV18 [GeForce4 MX 440 AGP 8x] (rev a2)
05:02.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5782 Gigabit Ethernet (rev 03)

Reply to: