[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#298274: Package: installation-reports

Package: installation-reports

Debian-installer-version: On 2005/03/06 JST, got "Working" netboot
from http://people.debian.org/~joeyh/d-i/images/daily/netboot/debian-installer/i386/
uname -a: Linux Debian 2.4.27-2-686 #1 Thu Jan 20 11:10:41 JST 2005
i686 GNU/Linux
Date: 2005/03/06, 13:30 JST
Method: Booted off NTFS as per the procedure at
http://marc.herbert.free.fr/linux/win2linstall.html . Then used either
ftp.jp.debian.org or ftp2.jp.debian.org (sorry forgot which exactly).
No proxy used. Connecting to internet via DHCP / 12Mbit ADSL

Machine: Fujitsu FMV-Biblio NB10AL
Processor: Celeron 1.066Ghz
Memory: 256Mb
Root Device: IDE /dev/hda
Root Size/partition table: 
  # fdisk -l /dev/hda

  Disk /dev/hda: 30.0 GB, 30005821440 bytes
  255 heads, 63 sectors/track, 3648 cylinders
  Units = cylinders of 16065 * 512 = 8225280 bytes

     Device Boot      Start         End      Blocks   Id  System
  /dev/hda1   *           1        2677    21502971    7  HPFS/NTFS
  /dev/hda2            3518        3648     1052257+   7  HPFS/NTFS
  /dev/hda3            2678        2919     1943865   83  Linux
  /dev/hda4            2920        3517     4803435    5  Extended
  /dev/hda5            2920        2950      248976   82  Linux swap
  /dev/hda6            2951        3517     4554396   83  Linux

  Partition table entries are not in disk order
Mounted /dev/hda3, 5 and 6.
Output of lspci and lspci -n:
# lspci
0000:00:00.0 Host bridge: Intel Corp. 82830 830 Chipset Host Bridge (rev 04)
0000:00:02.0 VGA compatible controller: Intel Corp. 82830 CGC [Chipset
Graphics Controller] (rev 04)
0000:00:02.1 Display controller: Intel Corp. 82830 CGC [Chipset
Graphics Controller]
0000:00:1d.0 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #1) (rev 02)
0000:00:1d.1 USB Controller: Intel Corp. 82801CA/CAM USB (Hub #2) (rev 02)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 42)
0000:00:1f.0 ISA bridge: Intel Corp. 82801CAM ISA Bridge (LPC) (rev 02)
0000:00:1f.1 IDE interface: Intel Corp. 82801CAM IDE U100 (rev 02)
0000:00:1f.3 SMBus: Intel Corp. 82801CA/CAM SMBus Controller (rev 02)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801CA/CAM
AC'97 Audio Controller (rev 02)
0000:00:1f.6 Modem: Intel Corp. 82801CA/CAM AC'97 Modem Controller (rev 02)
0000:01:0a.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus
Controller (rev 01)
0000:01:0a.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus
Controller (rev 01)
0000:01:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
0000:01:0e.0 FireWire (IEEE 1394): Fujitsu Limited.: Unknown device
2010 (rev 01)
# lspci -n 
0000:00:00.0 0600: 8086:3575 (rev 04)
0000:00:02.0 0300: 8086:3577 (rev 04)
0000:00:02.1 0380: 8086:3577
0000:00:1d.0 0c03: 8086:2482 (rev 02)
0000:00:1d.1 0c03: 8086:2484 (rev 02)
0000:00:1e.0 0604: 8086:2448 (rev 42)
0000:00:1f.0 0601: 8086:248c (rev 02)
0000:00:1f.1 0101: 8086:248a (rev 02)
0000:00:1f.3 0c05: 8086:2483 (rev 02)
0000:00:1f.5 0401: 8086:2485 (rev 02)
0000:00:1f.6 0703: 8086:2486 (rev 02)
0000:01:0a.0 0607: 104c:ac55 (rev 01)
0000:01:0a.1 0607: 104c:ac55 (rev 01)
0000:01:0d.0 0200: 10ec:8139 (rev 10)
0000:01:0e.0 0c00: 10cf:2010 (rev 01)
Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


Originally tried using the rc2 netboot image, but had a problem
loading installer modules (same as this bug report:
http://lists.debian.org/debian-boot/2005/03/msg00103.html). Tried
again using the Working version, everything seemed to go smoothly, no
roadbumps at all.

Previously I have installed Debian 3.0r1 off CD onto a pretty old
Pentium multiple times, so this installer was new to me. In particular
I got a little bit confused / concerned at the partitioning stage,
because I wasn't familiar with the icons used to represent things like
the bootable primary partition, and all those white smiley faces
against the Linux partitions. I managed to find the explanations for
all of this in a screen linked to from the top of that page. However,
I found that the installer had marked the linux root parition
/dev/hda3 as bootable - I was a bit worried since I had just made the
/dev/hda1 NTFS partition bootable prior to this and wasn't sure why
this change was being made. I had backups though so went ahead and
trusted the installer - at the next step the Windows XP installation
was correctly detected, and GRUB set everything up, and so I didn't
have anything to worry about. But when filling out this report I see
my fdisk -ls is showing that /dev/hda1 is bootable again. Confused,
but at least everything is working.

Otherwise, good job!!

Reply to: