[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#293859: marked as done (installation-report)

Your message dated Fri, 11 Feb 2005 20:47:02 -0500
with message-id <E1CzmNC-00049k-00@newraff.debian.org>
and subject line Bug#293859: fixed in os-prober 1.03
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 6 Feb 2005 12:00:16 +0000
>From mfuzzey@tele2.fr Sun Feb 06 04:00:15 2005
Return-path: <mfuzzey@tele2.fr>
Received: from mailfe08.swip.net [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1Cxl5J-00016H-00; Sun, 06 Feb 2005 04:00:13 -0800
X-T2-Posting-ID: ySKDWQndlMQvKiA1yJPKqkfcXIJceBnCUU5jpPQF2pA=
Received: from [] (HELO srv002.fuzzey.net)
  by mailfe08.swip.net (CommuniGate Pro SMTP 4.2.7)
  with ESMTP id 91958764 for submit@bugs.debian.org; Sun, 06 Feb 2005 12:59:40 +0100
Received: from localhost (localhost [])
	by srv002.fuzzey.net (Postfix) with ESMTP id EE48ABC004
	for <submit@bugs.debian.org>; Sun,  6 Feb 2005 12:59:35 +0100 (CET)
Received: from srv002.fuzzey.net ([])
	by localhost (srv002.fuzzey.net []) (amavisd-new, port 10024)
	with ESMTP id 18085-07 for <submit@bugs.debian.org>;
	Sun, 6 Feb 2005 12:59:18 +0100 (CET)
Received: from [] (wifi-dhcp-1.fuzzey.net [])
	by srv002.fuzzey.net (Postfix) with ESMTP id EA42CBC003
	for <submit@bugs.debian.org>; Sun,  6 Feb 2005 12:59:17 +0100 (CET)
Message-ID: <[🔎] 420606A8.5060403@fuzzey.net>
Date: Sun, 06 Feb 2005 12:59:36 +0100
From: Martin Fuzzey <mfuzzey@tele2.fr>
Reply-To: mfuzzey@mailclub.net
User-Agent: Mozilla Thunderbird 0.9 (X11/20041124)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: submit@bugs.debian.org
Subject: installation-report
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-Virus-Scanned: by amavisd-new-20030616-p10 (Debian) at fuzzey.net
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02

Package: installation-reports

Debian-installer-version: RC2 22 Nov 2004 debian.org
uname -a: Linux version 2.4.27-1-386 (joshk@trollwife) (gcc version 3.3.4 (Debian 1:3.3.4-9)) #1 Fri Sep 3 06:24:46 UTC 2004   (taken from syslog -i'm now running 2.6)
Date: Jan 30 2005 16:30
Method: Boot from CD image
Machine: HP Pavilion zv5340EA
Processor: AMD64
Memory: 512K
Root Device: IDE hda
Root Size/partition table: 
Minor    Start       End     Type      Filesystem  Flags
1          0.031  47998.894  primary   ntfs        boot   on /mnt/windows
2      47998.894  75132.114  primary   ext3		  on /
3      75132.114  76316.594  extended              lba
5      75132.145  76316.594  logical   linux-swap

Output of lspci and lspci -n:
portableHP:/var/log# lspci
0000:00:00.0 Host bridge: nVidia Corporation nForce3 Host Bridge (rev a4)
0000:00:01.0 ISA bridge: nVidia Corporation nForce3 LPC Bridge (rev a6)
0000:00:01.1 SMBus: nVidia Corporation nForce3 SMBus (rev a4)
0000:00:02.0 USB Controller: nVidia Corporation nForce3 USB 1.1 (rev a5)
0000:00:02.1 USB Controller: nVidia Corporation nForce3 USB 1.1 (rev a5)
0000:00:02.2 USB Controller: nVidia Corporation nForce3 USB 2.0 (rev a2)
0000:00:06.0 Multimedia audio controller: nVidia Corporation nForce3 Audio (rev a2)
0000:00:06.1 Modem: nVidia Corporation: Unknown device 00d9 (rev a2)
0000:00:08.0 IDE interface: nVidia Corporation nForce3 IDE (rev a5)
0000:00:0a.0 PCI bridge: nVidia Corporation nForce3 PCI Bridge (rev a2)
0000:00:0b.0 PCI bridge: nVidia Corporation nForce3 AGP Bridge (rev a4)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 440 Go 64M] (rev a3)
0000:02:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
0000:02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
0000:02:04.0 CardBus bridge: Texas Instruments: Unknown device ac54 (rev 01)
0000:02:04.1 CardBus bridge: Texas Instruments: Unknown device ac54 (rev 01)
0000:02:04.2 System peripheral: Texas Instruments: Unknown device 8201 (rev 01)

portableHP:/var/log# lspci -n
0000:00:00.0 0600: 10de:00d1 (rev a4)
0000:00:01.0 0601: 10de:00d0 (rev a6)
0000:00:01.1 0c05: 10de:00d4 (rev a4)
0000:00:02.0 0c03: 10de:00d7 (rev a5)
0000:00:02.1 0c03: 10de:00d7 (rev a5)
0000:00:02.2 0c03: 10de:00d8 (rev a2)
0000:00:06.0 0401: 10de:00da (rev a2)
0000:00:06.1 0703: 10de:00d9 (rev a2)
0000:00:08.0 0101: 10de:00d5 (rev a5)
0000:00:0a.0 0604: 10de:00dd (rev a2)
0000:00:0b.0 0604: 10de:00d2 (rev a4)
0000:00:18.0 0600: 1022:1100
0000:00:18.1 0600: 1022:1101
0000:00:18.2 0600: 1022:1102
0000:00:18.3 0600: 1022:1103
0000:01:00.0 0300: 10de:0179 (rev a3)
0000:02:00.0 0c00: 104c:8026
0000:02:01.0 0200: 10ec:8139 (rev 10)
0000:02:02.0 0280: 14e4:4320 (rev 03)
0000:02:04.0 0607: 104c:ac54 (rev 01)
0000:02:04.1 0607: 104c:ac54 (rev 01)
0000:02:04.2 0880: 104c:8201 (rev 01)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]  -  but NTFS resize problem (see below)
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O] 
Install boot loader:    [E]
Reboot:                 [ ]

The NTFS resize from d-i didn't work - no error message it just returned me to the partition screen with no changes after asking for the new size and warning me it would have to write.
I tried qtparted from a system resuce CD and that gave me an error message indicating that the NTFS partition was inconsistant. 
Running chkdsk /f from windows fixed it - unfortunately I didn't try to resize after that from d-i but did it from qtparted. 
I let d-i create the new linux partitions in the free space thus created.
I suspect that the NTFS partition error was also the reason d-i didn't work but an error message would have been nice

The install boot loader phase seemed to "lock up" at the 33% stage [Installing GRUB Boot Loader / Determining GRUB Boot Device] 
The machine itself was NOT locked however, I could switch to a console and login with ssh if i tried doing a remote install in expert mode.
The problem was 100% reproducable - I rebooted several times and it always stopped at the same place.

Running with DEBCONF_DEBUG=5 gave this at the end of my syslog :

Jan 30 16:30:18 debconf: --> SUBST grub-installer/with_other_os OS_LIST 
Microsoft Windows XP dition familiale    <--- This is French XP Home with an acute accent on edition...

Jan 30 16:30:18 debconf: Adding [OS_LIST] -> [Microsoft Windows XP 
dition familiale]

Jan 30 16:30:18 debconf: <-- 0

Jan 30 16:30:18 debconf: --> PROGRESS STEP 1

Jan 30 16:30:18 debconf: <-- 0 OK

Jan 30 16:30:18 debconf: --> PROGRESS INFO 

Jan 30 16:30:18 debconf: <-- 0 OK

Jan 30 16:30:18 debconf: --> INPUT high grub-installer/with_other_os

Jan 30 16:30:18 debconf: <-- 0 question will be asked

Jan 30 16:30:18 debconf: --> GO

It appears the GO command to the installer UI never returned...
(I wasn' asked any questions here as I should have been...)

I finally completed the install manually by doing the grub install stuff manually, rebooting and running base-config which gave me a working system.

In spite of this problem I was pleased with the installer. It was all very easy to understand.

Martin Fuzzey

Received: (at 293859-close) by bugs.debian.org; 12 Feb 2005 01:53:04 +0000
>From katie@ftp-master.debian.org Fri Feb 11 17:53:04 2005
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CzmT2-0005x1-00; Fri, 11 Feb 2005 17:53:04 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1CzmNC-00049k-00; Fri, 11 Feb 2005 20:47:02 -0500
From: Joey Hess <joeyh@debian.org>
To: 293859-close@bugs.debian.org
X-Katie: $Revision: 1.55 $
Subject: Bug#293859: fixed in os-prober 1.03
Message-Id: <E1CzmNC-00049k-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Fri, 11 Feb 2005 20:47:02 -0500
Delivered-To: 293859-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2005_01_02 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2005_01_02
X-CrossAssassin-Score: 2

Source: os-prober
Source-Version: 1.03

We believe that the bug you reported is fixed in the latest version of
os-prober, which is due to be installed in the Debian FTP archive:

  to pool/main/o/os-prober/os-prober_1.03.dsc
  to pool/main/o/os-prober/os-prober_1.03.tar.gz
  to pool/main/o/os-prober/os-prober_1.03_i386.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 293859@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated os-prober package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Fri, 11 Feb 2005 20:30:56 -0500
Source: os-prober
Binary: os-prober
Architecture: source i386
Version: 1.03
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 os-prober  - utility to detect other OSes on a set of drives (udeb)
Closes: 273960 293859
 os-prober (1.03) unstable; urgency=low
   * Joey Hess
     - Applied patch from Guillem Jover to detect many redhat derived
   * Frans Pop
     - Exclude partitions that are part of a software raid array.
       Closes: #273960.
     - Don't use the description from Windows' boot.ini if it contains
       non-ascii (or other unusual) characters. Closes: #293859.
   * Colin Watson
     - Probe ext3, xfs, and jfs modules too.
 1fd72645796fea46ed7f7fe1b8a9fa4e 594 debian-installer optional os-prober_1.03.dsc
 01afada0801c77b43fbd4e3b77e7f09e 11693 debian-installer optional os-prober_1.03.tar.gz
 afb40f44a627e39806de890bda83a962 6540 debian-installer optional os-prober_1.03_i386.udeb
package-type: udeb

Version: GnuPG v1.4.0 (GNU/Linux)


Reply to: