[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#293859: installation-report

Package: installation-reports

Debian-installer-version: RC2 22 Nov 2004 debian.org
uname -a: Linux version 2.4.27-1-386 (joshk@trollwife) (gcc version 3.3.4 (Debian 1:3.3.4-9)) #1 Fri Sep 3 06:24:46 UTC 2004   (taken from syslog -i'm now running 2.6)
Date: Jan 30 2005 16:30
Method: Boot from CD image
Machine: HP Pavilion zv5340EA
Processor: AMD64
Memory: 512K
Root Device: IDE hda
Root Size/partition table: Minor Start End Type Filesystem Flags
1          0.031  47998.894  primary   ntfs        boot   on /mnt/windows
2      47998.894  75132.114  primary   ext3		  on /
3      75132.114  76316.594  extended              lba
5      75132.145  76316.594  logical   linux-swap

Output of lspci and lspci -n:
portableHP:/var/log# lspci
0000:00:00.0 Host bridge: nVidia Corporation nForce3 Host Bridge (rev a4)
0000:00:01.0 ISA bridge: nVidia Corporation nForce3 LPC Bridge (rev a6)
0000:00:01.1 SMBus: nVidia Corporation nForce3 SMBus (rev a4)
0000:00:02.0 USB Controller: nVidia Corporation nForce3 USB 1.1 (rev a5)
0000:00:02.1 USB Controller: nVidia Corporation nForce3 USB 1.1 (rev a5)
0000:00:02.2 USB Controller: nVidia Corporation nForce3 USB 2.0 (rev a2)
0000:00:06.0 Multimedia audio controller: nVidia Corporation nForce3 Audio (rev a2)
0000:00:06.1 Modem: nVidia Corporation: Unknown device 00d9 (rev a2)
0000:00:08.0 IDE interface: nVidia Corporation nForce3 IDE (rev a5)
0000:00:0a.0 PCI bridge: nVidia Corporation nForce3 PCI Bridge (rev a2)
0000:00:0b.0 PCI bridge: nVidia Corporation nForce3 AGP Bridge (rev a4)
0000:00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
0000:01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 440 Go 64M] (rev a3)
0000:02:00.0 FireWire (IEEE 1394): Texas Instruments TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
0000:02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:02:02.0 Network controller: Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller (rev 03)
0000:02:04.0 CardBus bridge: Texas Instruments: Unknown device ac54 (rev 01)
0000:02:04.1 CardBus bridge: Texas Instruments: Unknown device ac54 (rev 01)
0000:02:04.2 System peripheral: Texas Instruments: Unknown device 8201 (rev 01)

portableHP:/var/log# lspci -n
0000:00:00.0 0600: 10de:00d1 (rev a4)
0000:00:01.0 0601: 10de:00d0 (rev a6)
0000:00:01.1 0c05: 10de:00d4 (rev a4)
0000:00:02.0 0c03: 10de:00d7 (rev a5)
0000:00:02.1 0c03: 10de:00d7 (rev a5)
0000:00:02.2 0c03: 10de:00d8 (rev a2)
0000:00:06.0 0401: 10de:00da (rev a2)
0000:00:06.1 0703: 10de:00d9 (rev a2)
0000:00:08.0 0101: 10de:00d5 (rev a5)
0000:00:0a.0 0604: 10de:00dd (rev a2)
0000:00:0b.0 0604: 10de:00d2 (rev a4)
0000:00:18.0 0600: 1022:1100
0000:00:18.1 0600: 1022:1101
0000:00:18.2 0600: 1022:1102
0000:00:18.3 0600: 1022:1103
0000:01:00.0 0300: 10de:0179 (rev a3)
0000:02:00.0 0c00: 104c:8026
0000:02:01.0 0200: 10ec:8139 (rev 10)
0000:02:02.0 0280: 14e4:4320 (rev 03)
0000:02:04.0 0607: 104c:ac54 (rev 01)
0000:02:04.1 0607: 104c:ac54 (rev 01)
0000:02:04.2 0880: 104c:8201 (rev 01)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]  -  but NTFS resize problem (see below)
Create file systems:    [O]
Mount partitions:       [O]
Install base system: [O] Install boot loader: [E]
Reboot:                 [ ]

The NTFS resize from d-i didn't work - no error message it just returned me to the partition screen with no changes after asking for the new size and warning me it would have to write.
I tried qtparted from a system resuce CD and that gave me an error message indicating that the NTFS partition was inconsistant. Running chkdsk /f from windows fixed it - unfortunately I didn't try to resize after that from d-i but did it from qtparted. I let d-i create the new linux partitions in the free space thus created.
I suspect that the NTFS partition error was also the reason d-i didn't work but an error message would have been nice

The install boot loader phase seemed to "lock up" at the 33% stage [Installing GRUB Boot Loader / Determining GRUB Boot Device] The machine itself was NOT locked however, I could switch to a console and login with ssh if i tried doing a remote install in expert mode.
The problem was 100% reproducable - I rebooted several times and it always stopped at the same place.

Running with DEBCONF_DEBUG=5 gave this at the end of my syslog :

Jan 30 16:30:18 debconf: --> SUBST grub-installer/with_other_os OS_LIST Microsoft Windows XP dition familiale <--- This is French XP Home with an acute accent on edition...

Jan 30 16:30:18 debconf: Adding [OS_LIST] -> [Microsoft Windows XP dition familiale]

Jan 30 16:30:18 debconf: <-- 0

Jan 30 16:30:18 debconf: --> PROGRESS STEP 1

Jan 30 16:30:18 debconf: <-- 0 OK

Jan 30 16:30:18 debconf: --> PROGRESS INFO grub-installer/progress/step_bootdev

Jan 30 16:30:18 debconf: <-- 0 OK

Jan 30 16:30:18 debconf: --> INPUT high grub-installer/with_other_os

Jan 30 16:30:18 debconf: <-- 0 question will be asked

Jan 30 16:30:18 debconf: --> GO

It appears the GO command to the installer UI never returned...
(I wasn' asked any questions here as I should have been...)

I finally completed the install manually by doing the grub install stuff manually, rebooting and running base-config which gave me a working system.

In spite of this problem I was pleased with the installer. It was all very easy to understand.

Martin Fuzzey

Reply to: