[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#293008: Sarge Installation Report: succes, but strange tasksel behavior

Package: installation-reports


Installation was very smooth. One very strange hick-up of tasksel 
at the end (or /me getting too old to touch computers ?).

Debian-installer-version:  downloaded sarge install CD 01 (.iso) on
  22 Jan 2005 from the official site (ftp.acc.umu.se)
uname -a: Linux kessel2 2.6.8-1-386 #1 Thu Nov 25 04:24:08 UTC 2004 i586

Date: 31 Jan 2005 16:00 CET
Method: How did you install?
  Put CD in system, rebooted, chose
  boot: linux26
  further machine was connected to the Internet

(this is a reinstall of the box from last week
 (was bug report 291950), since I found the
 partitioning was too broken for me to figure out
 how to repair it; cfdisk and fdisk reported errors
 on it. I do have the old fdisk report available 
 if needed.)

Machine: "white box" (old)
Processor: GenuineIntel Pentium MMX 233 MHz
Memory: total: 130510848
Root Device: /dev/hdb

I chose the automatic partitioning for "server with multiple users"
and this yielded the below structure. This matches very well with
what I expected.

Root Size/partition table:

Disk /dev/hdb: 33.8 GB, 33820286976 bytes
16 heads, 63 sectors/track, 65531 cylinders
Units = cylinders of 1008 * 512 = 516096 bytes

   Device Boot      Start         End      Blocks   Id  System
   /dev/hdb1   *           1         543      273640+  83  Linux
   /dev/hdb2             544       65531    32753952    f  W95 Ext'd
   /dev/hdb5             544       10231     4882720+  83  Linux
   /dev/hdb6           10232       16044     2929720+  83  Linux
   /dev/hdb7           16045       16782      371920+  82  Linux swap
   /dev/hdb8           16783       17557      390568+  83  Linux
   /dev/hdb9           17558       65531    24178864+  83  Linux

(I am actually curious why I get a W95 Ext'd (LBA) ?)

Output of lspci and lspci -n:

kessel2:~# lspci
0000:00:00.0 Host bridge: Intel Corp. 430TX - 82439TX MTXC (rev 01)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 01)
0000:00:13.0 VGA compatible controller: S3 Inc. ViRGE/DX or /GX (rev 01)
0000:00:14.0 Ethernet controller: Realtek Semiconductor Co., Ltd.  
RTL-8139/8139C/8139C+ (rev 10)
kessel2:~# lspci -n
0000:00:00.0 0600: 8086:7100 (rev 01)
0000:00:07.0 0601: 8086:7110 (rev 01)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 01)
0000:00:13.0 0300: 5333:8a01 (rev 01)
0000:00:14.0 0200: 10ec:8139 (rev 10)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


I choose (again) Dutch/Belgium as language and us (Qwerty) as keyboard
(this of course yielded incorrect X configuration, but that is a known

At the end of the install, I acitvated tasksel with it's default set-up
(only "Mail server" activated). The system went on to correctly install
the additional packages.

After that, from a root prompt (obviously in console since no X was
installed yet), I ran tasksel. Tasksel came with Dutch language support. 
Then a very funny thing happened.

* I selected "Workstation" and did not select "Mail server"

the system proposed to install a lot of X related packages and to
*remove* exim. I was not aware that tasksel also removes packages ...
(by now I understand that it probably was removing exim in favor of

Anyway, since I did not want exim to be removed,  I pressed 'n' (I am
quite sure I did press 'n', since I was unhappy that the system would 
remove my already configured exim) but still the system continued with
downloading, installing and removing the packages as it had announced
... (or maybe I am just loosing it ... but I am really sure I pressed 
'n' since I was a little upset that tasksel would *remove* a package).

Is it at all possible that something went wrong in the translation or
something happened that strangely misinterpreted my 'n' for a yes ? I 
would be relieved if someone could confirm this bug (or am I getting 
too old to touch computers ?).

On a related thread, thrughout the installation, I was asked a number of
times for a (J/n) or (j/N) reply (in Dutch that is from "Ja" and "Neen"), 
but from pure habit, I pressed either 'y' or 'n'.. The system did not 
complain about me pressing a "wrong" button ('y' was no amidst the 
presented options). I have the impression that the system actually 
intepreted my 'y' for 'j', but now I am uncertain if this really
worked the way I had expected.

Hope This Helps,


Install logs and other status info is available in
Once you have filled out this report, mail it to submit@bugs.debian.org.

Reply to: