[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#291950: install report sarge on x86 2005-01-23

Package: installation-reports


As requested, I am sending an install report (succesfull) to 
the address submit@bugs.debian.org. I am willing to do more 
tests on this box if requested.

* 23 Jan 2005
* downloaded sarge install CD 01 (.iso) on 22 Jan 2005
  from the official site (ftp.acc.umu.se)

uname -a: Linux kessel-oud 2.4.27-1-386 #1 Wed Dec 1 19:43:08 JST 2004 i586 GNU/Linux

Date: 23 Jan 2005 (afternoon CET)

* burned a CD from the iso
* inserted into the box. The box did find CD OK and showed the
  image on screen. Pressed Enter to continue
* the install automagically used my Ethernet card (RTL-8139) to
  get a lot of stuff over the network

Machine: "white box" (old)

vendor_id       : GenuineIntel
cpu family      : 5
model           : 4
model name      : Pentium MMX
stepping        : 3
cpu MHz         : 233.870

total:    used:    free:  shared: buffers:  cached:
Mem:  130510848 91983872 38526976        0  8527872 49704960
Swap:        0        0        0
MemTotal:       127452 kB
MemFree:         37624 kB
MemShared:           0 kB
Buffers:          8328 kB
Cached:          48540 kB
SwapCached:          0 kB
Active:          55316 kB
Inactive:        24332 kB

Root Device: /dev/hdb

Root Size/partition table:

kessel-oud:~# cat /etc/fstab
# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hdb1       /               ext3    defaults,errors=remount-ro 0
/dev/hdb5       /home           ext3    defaults        0       2
/dev/hdb7       /tmp            ext3    defaults        0       2
/dev/hdb3       /usr            ext3    defaults        0       2
/dev/hdb6       /var            ext3    defaults        0       2
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
kessel-oud:~# df
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/hdb1               457656     76950    356289  18% /
tmpfs                    63724         0     63724   0% /dev/shm
/dev/hdb5             23790040     33796  22547756   1% /home
/dev/hdb7               521899      8252    485803   2% /tmp
/dev/hdb3              5767460   1692752   3781736  31% /usr
/dev/hdb6              1830230    111505   1621079   7% /var

Output of lspci and lspci -n:

kessel-oud:~# lspci
0000:00:00.0 Host bridge: Intel Corp. 430TX - 82439TX MTXC (rev 01)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 01)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 01)
0000:00:13.0 VGA compatible controller: S3 Inc. ViRGE/DX or /GX (rev 01)
0000:00:14.0 Ethernet controller: Realtek Semiconductor Co., Ltd.
RTL-8139/8139C/8139C+ (rev 10)
kessel-oud:~# lspci -n
0000:00:00.0 0600: 8086:7100 (rev 01)
0000:00:07.0 0601: 8086:7110 (rev 01)
0000:00:07.1 0101: 8086:7111 (rev 01)
0000:00:07.2 0c03: 8086:7112 (rev 01)
0000:00:07.3 0680: 8086:7113 (rev 01)
0000:00:13.0 0300: 5333:8a01 (rev 01)
0000:00:14.0 0200: 10ec:8139 (rev 10)

Base System Installation Checklist:

[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]  (difficult)
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]


* I used Nederlands (Belgium) as language

* I have a Qwerty (104) keyboard, and had difficulty:
  * finding it in the list (I choose English US and I hope that is Qwerty)
  * getting it in QWERTY mode (and not AZERTY ...)

==> proposed solution: in my view, a keyboard is not associated 
    with a country, but with a lay-out of the keys. So naming it as 
	* "AZERTY-BE-latin1"
	* "AZERTY-BE-latin2"
    makes a lot more sense to me.

* disk partitioning:
  * how the initial partioning worked was initially not clear to me ...
    (I have used fdisk for years and that just worked fine, and was
     also much faster ...)
  * I tried to salvage an existing /home partition, but I didn't
    understand how that should have worked and lost it (no big
    deal, this is a test machine, with no real data).
  * from the texts that are presented, it is unclear that to act on
    a partition (to reformat it or do other things), it needs to be
    selected with "return".

==> proposed solution: enter some text in the sense of:
    "To modify a partition, first select the partition with the 
     "up"/"down" arrows and then press "Enter". After pressing 
     "Enter", a next menu will be presented."

     (this seems quite verbose, but it would have helped me to 
      get this level of verbose explanation on how to access the
      details of a partition. I assume it will also help other
      less experienced users doing their first sarge install.)
  * having to go to a second-level menu for each partition and makes 
    it slower

* some language errors in the Dutch translation, these are sent to the
  Dutch translation list

* After an OK is entered to a certain question in a curses style screen, 
  there is no "ack" that the OK was received. The system just stays silent,
  is probably doing stuff in the background, but that is not clear from
  the User Interface.

==> poposed solution: add a reply message to the curses form e.g.:

    "Installation is continued"

    (may seem trivial, but when you have entered OK and _nothing_ seems to
     move or to happen, there is an automatic tendency to try OK again
     a few more times. This may cause errors, if exactly at that moment,
     a next question is asked.)

* Configuration of APT:

  * the system asks if you wish to install from a "mirror" server. IMO
    that is incorrect and lesse clear for novice users.  This server
    is not always a "mirror", it could be a primary server, and I 
    believe that for a user, it is more important to understand the 
    difference between an install over the network, as opposed to 
    an install from a CD, then to understand if this is a mirror, 
    or the original server.

==> proposed solution:

    "would you like to download packages over the network (from an 
     ftp or http server) ? If so, please tick the appropriate boxes."
  * only one entry is asked for the sources.list file. I really liked
    the woody install feature to ask if other servers need to be added.

==> proposed solution:

    execxute a while loop around this process and ask every time if
    the user wants to install an additional source of packages (sorry,
    but I don't have enough experience to implement that myself very 

* tasksel is quite limited in its options (but maybe that is good for
  a non-expert install ?) Of course, this is a place where it would not
  hurt to add an "extended" buttion, that just offers more finegrained

* I selected (IIRC) : desktop, file server, ...
  (in the meanwhile, I turned off Apple protocols as they boot quite slow)

* download speed for packages is excellent (600 KByte/s from kuleuven.ac.be)

* Why do I need to manually select my xserver (s3virge) if Knoppix and
  Ubuntu know that automagically ? For a newbe, this could be a
  showstopper. Would it be possible to try to figure out at least
  decent defaults (from lspci) in most cases ? I also looked into
  lspci and selected based on that. Many newbies would not know to go
  ALT-F2, log in as root, type lspci and find that info there.

==> I suggest to add a message to the selection screen in the sense of:

  "From an automatic scan of your hardware, it seems that the driver
   {s3virge|s3|...} is probably most appropriate."

* there is a routine for automagic detection of the mouse. This routine
  does not yield any feedback when it's done.
==> the system should give some feedback if this worked at all ...

* there is a routing that will try to automagically detect the correct
  screen (over I2C I assume). This should give some feedback ...

==> the system should give some feedback if this worked at all ...

* I entered s3virge and this actually worked :-) (in 800*600). 

* localisation/language was chosen as:

  * locality = Nederlands/Belgium
  * keyboard = English/US

  ==> in console mode this works correctly (keymap us)

  ==> in X / Gnome : it interpretes my keyboard as a
      Azerty ... (see below) :-/

* at the end of installation, it tries to start the X server.
  This seems to work for 3 times (3 times it restarts X, shows a
  correctly moving and "waiting" mouse pointer and then hangs
  the complete system). System does not respond to ssh login,
  no keyboard action whatsoever. So the only thing I could do
  was a power cycle.

* I restarted the entire system and now Gnome works correctly
  (but keyboard in Gnome is still incorrectly set as Azerty)

* back in console (Alt F1):

  mouse doesn't work :-/  (gpm mot installed)

* back in Gnome:

  going to
  "Toepassingen" -->
  "Bureaubladvoorkeuren" -->
  "Toegankelijkheid" -->

  For 10 seconds I get a "waiting mouse" and the message
  "Toetsenbord wordt gestart" en then it does not offer me any options
  to change the keyboard lay-out.

  going to
  "Toepassingen" -->
  "Bureaubladvoorkeuren" -->

  For 10 seconds I get a "waiting mouse" and the message
  "Toetsenbord wordt gestart" at the bottom of the screen and
  then it does not offer me any options to change the keyboard 
  lay-out (nothing comes up ...).

  After 20 seconds, the message at the bottom disappears, the
  mouse gets back to it static form, but I have seen nothing on
  the screen.

  Now I figure out that also synaptic does not execute anything ...

  Maybe I need to run Gnome as root to do this ...

* try to log on to Gnome as root ==> Doesn't work (obviously)
  "De systeembeheerder mag zich niet op aanmelden op dit scherm"

* Gnome: when trying to reboot: An english message appears:
  "Please enter root password to reboot" (this should have been
  a Dutch message to be exact)

* Now I try again as user "peter" and funny, now the user "peter" 
  can suddenly change his own keyboard settings ==> keyboard QWERTY 
  now works for user peter ...
  Maybe because I selected "Standaard Systeem sessie" (I don't
  recall exactly ?)

* rebooted the and went into XF86Config-4 to change the keyboard
  setting manually from 'be' to 'us' . Also added gpmdata to make
  it work with gpm repeat.

  <       Option          "XkbModel"      "pc104"
  <       Option          "XkbLayout"     "us"
  >       Option          "XkbModel"      "pc105"
  >       Option          "XkbLayout"     "be"
  <       Option          "Device"                "/dev/gpmdata"
  >       Option          "Device"                "/dev/psaux"

Now it works like a charm (just a little slow with a 233 MHz CPU :-p)

Once you have filled out this report, mail it to submit@bugs.debian.org



Reply to: