[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#291362: installation-reports: LVM install failed due to missing dmsetup



Package: installation-reports
Severity: important

Debian-installer-version:
	http://cdimage.debian.org/pub/cdimage-testing/daily/i386/current/sarge-i386-netinst.iso
	19-Jan-2005 23:05
uname -a: Install failed
Date: 2004-01-19 10:30
Method: CD-ROM based install
Machine: Homebrew
Processor: Athlon 64 3000
Memory: 1 GB
Root Device: Adaptec 2100S with two Fujitsu drives
Root Size/partition table: /boot as first 128 MB, rest of space in LVM,
	so / /var swap et al are on LVM LVs
Output of lspci and lspci -n:
	
Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [ ]

Comments/Problems:

Kernel installation (2.4.27) failed because the initrd could not be
generated. dmsetup is missing.

Root is on a DM device, but dmsetup not installed
Failed to create initrd image.

Same happens with 2.6.8.

Manually installing dmsetup as /target/sbin/dmsetup before installing
the base system cures the problem. The dmsetup package must be part of
the base system to solve this permanently.

-- System Information:
Debian Release: 3.1
  APT prefers testing
  APT policy: (990, 'testing'), (100, 'unstable')
Architecture: i386 (i686)
Kernel: Linux 2.4.27-lpc.6.k7
Locale: LANG=en_US, LC_CTYPE=en_US (charmap=ISO-8859-1)



Reply to: