[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Problem preseeding lilo-installer

On Wed, Dec 29, 2004 at 04:06:13PM +0300, Mikhail L. Titov wrote:
> Hello.
> For some reason I would like to use lilo instead of grub. But when I specify
> d-i        grub-installer/skip                boolean true
> and no more about lilo, then during installation I get
> [!!] Install the LILO boot loader on a hard disk
> Installation step failed
> . On tty4 I saw mention about "dev/ide/host0/bus0/target0/lun0/part1//dev/ide/host0/bus0/target0/lun0".
notice the double information

> And I can manually continue installation.
> Trying to write
> d-i     lilo-installer/activate-part    boolean true
> d-i     lilo-installer/bootdev  select   /dev/hda: Master Boot Record
> d-i     lilo-installer/apt-install-failed       boolean yes
> is also helpless. I have even tried
> d-i    lilo-installer/bootdev  select  Other choice (Advanced)
> d-i    lilo-installer/manual_bootdev   string  /dev/ide/host0/bus0/target0/lun0/disc
delete that line ( make it comment )

> with the same result. Furthemore with these or previous settings I can't continue interactive installation.
> I didn't achieved silent installation.
> I have debconf/priority=critical.
Why?  (I didn't set debconf/priority for my silent installations)

> Are there are any suggestions ?

Sorry, right now only obvious things as

* read the fine manual
* if manual fails, then read the source
* be aware of bugs
* create a good test environment

Geert Stappers

Attachment: signature.asc
Description: Digital signature

Reply to: