[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283214: RC2: grub failed but lilo ok on HP Proliant DL 380

Package: installation-reports

Debian-installer-version: http://cdimage.debian.org/pub/cdimage-testing/sarge_d-i/i386/rc2/sarge-i386-netinst.iso donwloaded 26/11/04
uname -a: sorry dont have access to the machine anymore but kernel is 2.6.8-1-386
Date: 26/11/04
Method: net install no proxy

Machine: HP Proliant DL 380 (RAID 1 hardware config)
Processor: Xeon (not sure)
Memory: 1 Gb
Root Device: SCSI
Root Size/partition table: nothing special here, many tries, simple / and swap give the same result see above. Output of lspci and lspci -n: sorry dont have access to the machine anymore

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [E]
Reboot:                 [O]


GRUB failed to install during the installation process but LILO does the job.
Many tries and nothing special here simple / and swap give the same result (GRUB failed)

If grub is installed after the installation process then grub install is OK but then during the boot i've got
pivot_root no such file or dir /sbin/init:426
cannot open dev/console!no such file
kernel panic

grub config is OK.
I think that this bug has nothing to do with the well known problem of the 3w_9xxx module because LILO has no problem at all.

Sorry but I don't have access to this machine anymore and can't give further information but this bug is
easy to reproduce on any HP Proliant DL 380 with debian installer pré-rc2 and rc2.

Reply to: