[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283104: Installation report on debian-installer

Package: installation-reports
Debian-installer-version: 26th Nov 04, from URL below
uname -a: Linux odyssey 2.4.26 #5 Wed Nov 17 13:55:55 GMT 2004 ppc GNU/Linux
Date: Multiple attempts
Method: Floppy boot using own kernel and root.img, then net install from
ftp.uk.linux.org, see below
Machine: IBM RS/6000 7025-F40
Processor: PowerPC 604e, 233MHz
Memory: 512MB
Root Device: SCSI, /dev/sda
Root Size/partition table: Probably not relevant
Output of lspci and lspci -n: Probably not relevant
Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [ ]
Load installer modules: [ ]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [E]
Install boot loader:    [ ]
Reboot:                 [ ]


Trying to install debian-testing onto an IBM 7025-F40 (PowerPC PReP) system
using the debian-installer from:


This machine is rather esoteric and requires a specially patched kernel to
boot it; I'm therefore trying to install by booting from a floppy containing a
kernel with all the necessary drivers in it and then using the root.img root
disk from the above location (this is the method I used to install the machine
using the old Debian installation system). I use the following boot parameters:

console=ttyS0,9600 load_ramdisk=1 ramdisk_size=32768 root=/dev/fd0

This starts up OK and gets me into the installer menu; I can then configure
country, language and keyboard OK, and opt to load drivers from the
net-drivers.img disk. This also works, although it generates an error
complaining about not being able to load kernel modules (because I'm using my
own kernel); it nevertheless loads the next debian-installer components OK.

I can then follow through the installation, configuring my hardware and
specifying to use the ftp.uk.linux.org mirror (I've also tried it manually
specifying a mirror at www.mirroservice.org), partitioning disks, etc., and
installing the base system.

The 'install the base system' part works fine until it reaches the point at
which it tries to install a kernel. This fails, presumably because I'm using
my own kernel. The trouble is, I can't progress the installation any further
at this point - if I try to select any other option from the main menu, it
just tries to re-run the 'install base system' part again. There seems to be
no way out, and I'm left with an unbootable system.

Since I can't use one of the standard kernels on my system anyway, would it be
possible to have the 'install kernel' menu offer an option to 'not install a
kernel and skip this step' - I could then finish off the installation and
manually put in a kernel from floppy via the command line later on.

Weird hardware like this is never going to be straightforward, but at least
with the old install system I could get it working reasonably easily! ;-)

Let me know if you want the .config file for my custom kernel or the contents
of /var/log/messages from the broken install...



Reply to: