[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#283104: Installation report on debian-installer

On Fri, Nov 26, 2004 at 02:43:29PM +0000, Brian Ruth wrote:
> Package: installation-reports
> Debian-installer-version: 26th Nov 04, from URL below
> uname -a: Linux odyssey 2.4.26 #5 Wed Nov 17 13:55:55 GMT 2004 ppc GNU/Linux
> Date: Multiple attempts
> Method: Floppy boot using own kernel and root.img, then net install from
> ftp.uk.linux.org, see below
> Machine: IBM RS/6000 7025-F40
> Processor: PowerPC 604e, 233MHz
> Memory: 512MB
> Root Device: SCSI, /dev/sda
> Root Size/partition table: Probably not relevant
> Output of lspci and lspci -n: Probably not relevant
> Base System Installation Checklist:
> [O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it
> Initial boot worked:    [O]
> Configure network HW:   [O]
> Config network:         [O]
> Detect CD:              [ ]
> Load installer modules: [ ]
> Detect hard drives:     [O]
> Partition hard drives:  [O]
> Create file systems:    [O]
> Mount partitions:       [O]
> Install base system:    [E]
> Install boot loader:    [ ]
> Reboot:                 [ ]
> Comments/Problems:
> Trying to install debian-testing onto an IBM 7025-F40 (PowerPC PReP) system
> using the debian-installer from:
> http://ftp.debian.org/debian/dists/sarge/main/installer-powerpc/current/images/powerpc/floppy-2.4/
> This machine is rather esoteric and requires a specially patched kernel to
> boot it; I'm therefore trying to install by booting from a floppy containing a
> kernel with all the necessary drivers in it and then using the root.img root
> disk from the above location (this is the method I used to install the machine

floppy install on powerpc on anything except old world powermacs are not
currently supported. If there is a special patch needed for the kernel, please
inform us about it, and let's try to get it in the official kernels. Can you
try booting the plain 2.4.27 and 2.6.8 debian official kernels (the latest
needs some mkvmlinuz invocation before it is usefull to you). That said, there
where a bunch of prep patches which got into the 2.6.8 kernel, so it may be
that it will work already.

Once we have a working kernel, we can go ahead and see if we can produce a
prep floppy set, but first we need a working kernel.

Also, did you try the netboot method with either : 


(i guess your box uses the prep boot, and not ppcbug), or :


the initrd size may be too big for your prep OF, and you may want to try :


Altough i believe that it doesn't contain yet the needed prep modules and
such, since it was hand-crafter for pegasos1, but i know there is also a
initrd size limit on some prep systems, which make the above system a good

> using the old Debian installation system). I use the following boot parameters:
> console=ttyS0,9600 load_ramdisk=1 ramdisk_size=32768 root=/dev/fd0
> debconf/priority=medium
> This starts up OK and gets me into the installer menu; I can then configure
> country, language and keyboard OK, and opt to load drivers from the
> net-drivers.img disk. This also works, although it generates an error
> complaining about not being able to load kernel modules (because I'm using my
> own kernel); it nevertheless loads the next debian-installer components OK.
> I can then follow through the installation, configuring my hardware and
> specifying to use the ftp.uk.linux.org mirror (I've also tried it manually
> specifying a mirror at www.mirroservice.org), partitioning disks, etc., and
> installing the base system.
> The 'install the base system' part works fine until it reaches the point at
> which it tries to install a kernel. This fails, presumably because I'm using

Can you get us the exact error message (look at console 3 & 4 for details).

> my own kernel. The trouble is, I can't progress the installation any further
> at this point - if I try to select any other option from the main menu, it
> just tries to re-run the 'install base system' part again. There seems to be
> no way out, and I'm left with an unbootable system.

Notice that d-i doesn't know about the prep boot partition yet, so you woukd
have to use manual intervention anyway.

two things are needed, i believe, a partman-prep, based on the partman-alto
.udeb, and a way to install the kernel, which probably means a new
prep-installer .udeb package. You are the best candidate to implement this,
since you have access to the hardware,and an interest ti make it happen. I am
sure we will allbe willing to help you out on this.

> Since I can't use one of the standard kernels on my system anyway, would it be
> possible to have the 'install kernel' menu offer an option to 'not install a
> kernel and skip this step' - I could then finish off the installation and
> manually put in a kernel from floppy via the command line later on.

this would mean modifying base-installer i guess, i will let others comment on
this, bu this makes sense.

> Weird hardware like this is never going to be straightforward, but at least
> with the old install system I could get it working reasonably easily! ;-)

There is no reason for it not working out of the box, we just need someone
with knowledge and interrest to do the work, again, you are the ideal
candidate for this kind of stuff. Also, i gladly accept donation of a prep box
to make this kind of stuff happen.

> Let me know if you want the .config file for my custom kernel or the contents
> of /var/log/messages from the broken install...

please fill a bug report against the powerpc kernels,giving the patches you
used, the .config, and other details that may be relevant.

BTW, what kernel version did you try anyway ?


Sven Luther

Reply to: