[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#280811: Successful installation but system lockup very soon (screen frozen, no keyboard)

Package: installation-reports

Debian-installer-version: October 27, 2004, from Belgacom mirror (Belgium)
uname -a: Linux Shirka 2.6.8-1-386 #1 Mon Sep 13 23:29:55 EDT 2004 i686 GNU/Linux
Date: October 27, 2004
Method: net install, installation boot from CD

Machine: GMT Net
Processor: PIII Celeron 1.1 GHz
Memory: 128 MB, including 8 MB shared (for video)
Root Device: IDE (/dev/hda4)
Root Size/partition table:
4 physical partitions:
1: 6 GB NTFS
2: 5 GB ext2
3: 512 MB swap
4: 7.5 GB ext3

Output of lspci and lspci -n:
# lspci
0000:00:00.0 Host bridge: ALi Corporation M1621 (rev 04)
0000:00:01.0 PCI bridge: ALi Corporation PCI to AGP Controller (rev 01)
0000:00:02.0 USB Controller: ALi Corporation USB 1.1 Controller (rev 03)
0000:00:07.0 ISA bridge: ALi Corporation M1533 PCI to ISA Bridge
[Aladdin IV] (rev c3)
0000:00:0c.0 Multimedia audio controller: C-Media Electronics Inc CM8738
(rev 10)
0000:00:0c.1 Communication controller: C-Media Electronics Inc CM8738
(rev 20)
0000:00:0e.0 Ethernet controller: Silicon Integrated Systems [SiS]
SiS900 PCI Fast Ethernet (rev 02)
0000:00:0f.0 IDE interface: ALi Corporation M5229 IDE (rev c2)
0000:01:00.0 VGA compatible controller: nVidia Corporation NV5 [Aladdin
TNT2] (rev 20)

# lspci -n
0000:00:00.0 0600: 10b9:1621 (rev 04)
0000:00:01.0 0604: 10b9:5247 (rev 01)
0000:00:02.0 0c03: 10b9:5237 (rev 03)
0000:00:07.0 0601: 10b9:1533 (rev c3)
0000:00:0c.0 0401: 13f6:0111 (rev 10)
0000:00:0c.1 0780: 13f6:0211 (rev 20)
0000:00:0e.0 0200: 1039:0900 (rev 02)
0000:00:0f.0 0101: 10b9:5229 (rev c2)
0000:01:00.0 0300: 10de:00a0 (rev 20)

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:      [O]
Configure network HW:    [O]
Config network:                [ ]
Detect CD:              [ ]
Load installer modules: [O]
Detect hard drives:        [O]
Partition hard drives:   [O]
Create file systems:       [O]
Mount partitions:             [O]
Install base system:      [O]
Install boot loader:      [O]
Reboot:                               [O]


In two words:
- nearly no problem for installation and configuration,
- a major problem after a short usage time.

Here are the details.

I had to manually configure pppoe because
- installer did not propose to configure pppoe (only ppp)
- pppoeconf launched from another virtual console did not work.

-> edit configuration files in /etc/ppp/ and then pon dsl-provider.

I have seen these issues earlier in the mailing list.

After this the rest of the installation went without any problem.

The X server started with a 800x600 resolution, so I had to run
dpkg-reconfigure xserver-xfree86 again (after installation, thus) to
select the highest resolution available (1024x768).

I selected a "desktop environment" during installation, and I'm using

Suggestion: allow a finer-grain selection of the graphical environment
instead of full Gnome + full KDE + many applications:
- Gnome + gdm
- KDE + kdm
or maybe smaller subsets of the Gnome / KDE packages (without games,
etc.).  Similarly, having both OpenOffice.org suite + Abiword and
Gnumeric seems a bit strange, IMHO.

The keyboard was still considered an English one in X (gdm & gnome
session) even though I chose the correct type (105 / be) during
installation.  I had to set this value in GConf to make it work as

Now the serious part.

A few minutes after logging in Gnome, the system freezes.
- The display is blocked: mouse movements are not visible, application
windows do not change any more.
- The keyboard is not responding any more.  I tried the following
without any effect: Ctrl+w, Alt+F4, Ctrl+Backspace, NumLock,
Ctrl+Alt+F1.  I (humbly) admit I don't know how to use the "magic keys
combinations" recognized by the kernel, so I did not try them.

As far as I can tell the system is completely locked.

When does it occur? Rather randomly, but I can quickly reproduce the
problem if I use a graphics-intensive application like the screensaver
selector or background chooser.

I suspected something was wrong related to X, but neither XFree86.0.log
nor XFree86.0.log.old show any error message.

This system runs sarge without external components (for instance the
"nv" driver is used: the proprietary driver from nvidia is not
installed) and without recompiling the kernel (even though I will have
to recompile it anyway because the CM8738 sound driver does not seem to
be present).

Woody runs without any problem on another partition of the same PC. 
Also "nv" driver, kernel (2.4.21) recompiled.

Could someone give me some hints or directions for further

Thanks much!


Reply to: