[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#280810: installation-reports

Package: installation-reports

Debian-installer-version: 2004-11-06 - http://cdimage.debian.org/pub/cdimage-testing/sid_d-i/i386/pre-rc2/sarge-i386-netinst.iso

uname -a: Linux cee 2.4.27-1-386 #1 Fri Sep 3 06:24:46 UTC 2004 i686 GNU/Linux

Date: 2004-11-06 1pm PST

Method: I used the sarge net-install iso, and installed packages from ftp://linux.csua.berkeley.edu/debian/ with no proxy. The installer configured my NIC to my Belkin router after auto-detecting most of the network settings correctly.

Machine: Compaq Presario 4410US
Processor: 1.3Ghz Celeron
Memory: 512 MB (2 x 256MB SDRAM, PC133)
Root Device: 40gb hard drive IDE
Root Size/partition table:
No. 	Type		Start 	End 	Use 	
1 	NTFS		1 	3390 	/mnt/xp
2 	Linux ext2fs	3391 	3404 	MBR
3 	Linux ext2fs 	3405 	4823 	/
4 	Extended 	4824 	5169
5 	Linux ext2fs 	4824 	4892 	swap
6 	FAT32 Shared 	4893 	5169 	/mnt/linwin

Output of lspci and lspci -n:
c@cee:~$ lspci
0000:00:00.0 Host bridge: Intel Corp. 82815 815 Chipset Host Bridge and Memory Controller Hub (rev 04) 0000:00:02.0 VGA compatible controller: Intel Corp. 82815 CGC [Chipset GraphicsController] (rev 04)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev 05)
0000:00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 05)
0000:00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 05)
0000:00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 05)
0000:00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 05)
0000:00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 05)
0000:02:0d.0 Communication controller: Conexant HSF 56k HSFi Modem (rev 01)
0000:02:0f.0 Ethernet controller: National Semiconductor Corporation DP83815 (MacPhyter) Ethernet Controller

c@cee:~$ lspci -n
0000:00:00.0 0600: 8086:1130 (rev 04)
0000:00:02.0 0300: 8086:1132 (rev 04)
0000:00:1e.0 0604: 8086:244e (rev 05)
0000:00:1f.0 0601: 8086:2440 (rev 05)
0000:00:1f.1 0101: 8086:244b (rev 05)
0000:00:1f.2 0c03: 8086:2442 (rev 05)
0000:00:1f.4 0c03: 8086:2444 (rev 05)
0000:00:1f.5 0401: 8086:2445 (rev 05)
0000:02:0d.0 0780: 14f1:2f00 (rev 01)
0000:02:0f.0 0200: 100b:0020

Base System Installation Checklist:
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [O]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]

Everything worked wonderfully! A joy compared to my many attempts at woody (I could never get the network setup). I only wish that if Desktop System is selected, it would truly install and configure a windowing system. I had to manually install KDE and KDM, and then configure xFree86. I never could get XF86 correct with the config tools, I eventually just booted Knoppix, and copied the XF86Config-4 file from there. It'd be great if the "automatic X configuration" that Knoppix provides could be incorporated into a windowing setup script that lets you select, and install, your window manager. But at least with apt-get, and knoppix, it was easy enough!

Chris Martin
Web Developer
Open Source and Web Standards Advocate

Reply to: