[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Bug#249142: marked as done (The guided partitioning of whole drive with "sun" disk label does not work)

Your message dated Thu, 11 Nov 2004 13:02:02 -0500
with message-id <E1CSJGk-0000so-00@newraff.debian.org>
and subject line Bug#249142: fixed in partman-auto 40
has caused the attached Bug report to be marked as done.

This means that you claim that the problem has been dealt with.
If this is not the case it is now your responsibility to reopen the
Bug report if necessary, and/or fix the problem forthwith.

(NB: If you are a system administrator and have no idea what I am
talking about this indicates a serious mail system misconfiguration
somewhere.  Please contact me immediately.)

Debian bug tracking system administrator
(administrator, Debian Bugs database)

Received: (at submit) by bugs.debian.org; 14 May 2004 21:50:42 +0000
>From peter.karbaliotis@ualberta.ca Fri May 14 14:50:42 2004
Return-path: <peter.karbaliotis@ualberta.ca>
Received: from pilsener.srv.ualberta.ca [] 
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1BOkZm-0006fw-00; Fri, 14 May 2004 14:50:42 -0700
Received: from ualberta.ca (beast.cns.ualberta.ca [])
	by pilsener.srv.ualberta.ca (8.12.10/8.12.10) with ESMTP id i4ELofAB007752
	for <submit@bugs.debian.org>; Fri, 14 May 2004 15:50:41 -0600 (MDT)
Message-ID: <40A53F15.40903@ualberta.ca>
Date: Fri, 14 May 2004 15:50:13 -0600
From: Peter Karbaliotis <peter.karbaliotis@ualberta.ca>
Organization: University of Alberta
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040413 Debian/1.6-5
X-Accept-Language: en, el, ja
MIME-Version: 1.0
To: submit@bugs.debian.org
Subject: Installation report for Sun Ultra Enterprise 2
Content-Type: text/plain; charset=us-ascii; format=flowed
Content-Transfer-Encoding: 7bit
Delivered-To: submit@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-8.0 required=4.0 tests=BAYES_00,HAS_PACKAGE 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25
X-CrossAssassin-Score: 1

Package: installation-reports

Debian-installer-version: daily image 20040511 from 
uname -a: Linux pill 2.4.24-sparc64 #1 Fri Jan 30 18:32:22 EST 2004 
sparc64 unknown
Date: 20040514
Method: Network install from daily business card, sunsite.ualberta.ca, 
not proxied

Machine: Sun Ultra Enterprise 2
Processor: UltraSparc I
Memory: 1 GB
Root Device: SCSI, Seagate ST32550W 2.1GB, 
Root Size/partition table: see below
Output of lspci: N/A

Base System Installation Checklist:

Initial boot worked:    [O]
Configure network HW:   [O]
Config network:         [O]
Detect CD:              [O]
Load installer modules: [O]
Detect hard drives:     [O]
Partition hard drives:  [E]
Create file systems:    [O]
Mount partitions:       [O]
Install base system:    [O]
Install boot loader:    [O]
Reboot:                 [O]
[O] = OK, [E] = Error (please elaborate below), [ ] = didn't try it


Installed via serial console.

Using partman I wiped the old partition table and tried going through 
the guided partitioning.  It dies with the following:

Failed to partition the selected disk
This probably happened because there are too many (primary) partitions 
in the partition table.

Going back, this is what shows up:

SCSI1 (0,1,0) - 2.1 GB SEAGATE ST32550W SUNW2.1G
 > #1	785.2 MB B f ext3 /

Opening a shell and running parted I get the message
Warning: The disk CHS geometry (1009,67,62) does not match the geometry 
stored on the disk label (1009,19,80).

I then tried to recreate the disk label using 'mklabel sun'.  Going back 
to the menu and trying to partitin disks caused parted to segfault.

I started the install from the beginning and this time partitioning 
worked.  I had it use free space, all in one partition and got this result
SCSI1 (0,1,0) - 2.1 GB SEAGATE ST32550W SUNW2.1G
 > #1	2.0 GB	B	f	ext3	/
 > #2	127.6 MB	f	swap	swap

When the system rebooted I got the following message:
zs_close: bad serial port count; tty->count is 1, info->count is 3

In the second stage, the borders in the screens looked something like
3           3
3           3

Hitting return caused "^[[?1;2c" to appear at the bottom of the screen. 
  The same string appeared when trying to set the root password and the 
screen acted as if the return key had been entered.

Got the serial error message again:
zs_close: bad serial port count; tty->count is 1, info->count is 2

Running base-config again resulted in the correct border lines being 
shown and none of the above problems.

Contents of /proc/cpuinfo during install:
cpu : TI UltraSparc I (Spitfire)
fpu : UltraSparc I integrated FPU
promlib : Version 3 Revision 1
prom : 3.1.5
type : sun4u
ncpus probed : 2
ncpus active : 1
Cpu0Bogo : 399.76
Cpu0ClkTck : 000000000bebc200
MMU Type: Spitfire

Received: (at 249142-close) by bugs.debian.org; 11 Nov 2004 18:08:15 +0000
>From katie@ftp-master.debian.org Thu Nov 11 10:08:15 2004
Return-path: <katie@ftp-master.debian.org>
Received: from newraff.debian.org [] (mail)
	by spohr.debian.org with esmtp (Exim 3.35 1 (Debian))
	id 1CSJMl-0005p4-00; Thu, 11 Nov 2004 10:08:15 -0800
Received: from katie by newraff.debian.org with local (Exim 3.35 1 (Debian))
	id 1CSJGk-0000so-00; Thu, 11 Nov 2004 13:02:02 -0500
From: Joey Hess <joeyh@debian.org>
To: 249142-close@bugs.debian.org
X-Katie: $Revision: 1.51 $
Subject: Bug#249142: fixed in partman-auto 40
Message-Id: <E1CSJGk-0000so-00@newraff.debian.org>
Sender: Archive Administrator <katie@ftp-master.debian.org>
Date: Thu, 11 Nov 2004 13:02:02 -0500
Delivered-To: 249142-close@bugs.debian.org
X-Spam-Checker-Version: SpamAssassin 2.60-bugs.debian.org_2004_03_25 
	(1.212-2003-09-23-exp) on spohr.debian.org
X-Spam-Status: No, hits=-6.0 required=4.0 tests=BAYES_00,HAS_BUG_NUMBER 
	autolearn=no version=2.60-bugs.debian.org_2004_03_25

Source: partman-auto
Source-Version: 40

We believe that the bug you reported is fixed in the latest version of
partman-auto, which is due to be installed in the Debian FTP archive:

  to pool/main/p/partman-auto/partman-auto_40.dsc
  to pool/main/p/partman-auto/partman-auto_40.tar.gz
  to pool/main/p/partman-auto/partman-auto_40_all.udeb

A summary of the changes between this version and the previous one is

Thank you for reporting the bug, which will now be closed.  If you
have further comments please address them to 249142@bugs.debian.org,
and the maintainer will reopen the bug report if appropriate.

Debian distribution maintenance software
Joey Hess <joeyh@debian.org> (supplier of updated partman-auto package)

(This message was generated automatically at their request; if you
believe that there is a problem with it please contact the archive
administrators by mailing ftpmaster@debian.org)

Hash: SHA1

Format: 1.7
Date: Thu, 11 Nov 2004 01:46:37 -0500
Source: partman-auto
Binary: partman-auto
Architecture: source all
Version: 40
Distribution: unstable
Urgency: low
Maintainer: Debian Install System Team <debian-boot@lists.debian.org>
Changed-By: Joey Hess <joeyh@debian.org>
 partman-auto - Automatically partition storage devices (partman) (udeb)
Closes: 249142
 partman-auto (40) unstable; urgency=low
   * Add sun disk label write then read hack to autopartition script as was
     earlier done to other parts of partman to fix bug #237400.
   * Re-enable whole-device autopartitioning for sparc. Closes: #249142
   * Updated translations:
     - Italian (it.po) by Stefano Canepa
 1b990b7989ee31598d1e58a85d7a6c48 624 debian-installer standard partman-auto_40.dsc
 059302be19b863187ae1e1063dcd5818 51509 debian-installer standard partman-auto_40.tar.gz
 b1c4d81d39ff9eb8b937341502ad0bc9 35640 debian-installer standard partman-auto_40_all.udeb
package-type: udeb

Version: GnuPG v1.2.5 (GNU/Linux)


Reply to: